CVE-2023-28708 is a medium-severity (CVSS 4.3) CWE-523 vulnerability in org.apache.tomcat:tomcat-catalina. A fix is available for org.apache.tomcat:tomcat-catalina — see the affected versions and patch details below.
Apache Tomcat: JSESSIONID Cookie missing secure attribute in some configurations
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-28708.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.tomcat:tomcat-catalina☕org.apache.tomcat:tomcat-catalina☕org.apache.tomcat:tomcat-catalina☕org.apache.tomcat:tomcat-catalinaReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
When using the RemoteIpFilter with requests received from a reverse proxy via HTTP that include the X-Forwarded-Proto header set to https, session cookies created by Apache Tomcat 11.0.0-M1 to 11.0.0.-M2, 10.1.0-M1 to 10.1.5, 9.0.0-M1 to 9.0.71 and 8.5.0 to 8.5.85 did not include the secure attribute. This could result in the user agent transmitting the session cookie over an insecure channel.
Older, EOL versions may also be affected.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.tomcat:tomcat-catalina | ≥ 11.0.0-M1&&< 11.0.0-M3 | 11.0.0-M3org.apache.tomcat:tomcat-catalina:11.0.0-M3 |
| ☕Maven | org.apache.tomcat:tomcat-catalina | ≥ 10.1.0-M1&&< 10.1.6 | 10.1.6org.apache.tomcat:tomcat-catalina:10.1.6 |
| ☕Maven | org.apache.tomcat:tomcat-catalina | ≥ 9.0.0-M1&&< 9.0.72 | 9.0.72org.apache.tomcat:tomcat-catalina:9.0.72 |
| ☕Maven | org.apache.tomcat:tomcat-catalina | ≥ 8.5.0&&< 8.5.86 | 8.5.86org.apache.tomcat:tomcat-catalina:8.5.86 |
Affected Products
tomcatapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat-catalina, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.tomcat:tomcat-catalina to 11.0.0-M3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-28708 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
CVE-2023-28708 only potentially impacts a Tomcat configuration using a RemoteIpFilter behind a proxy or loadbalancer that sets an X-Forwarded-Proto request header with a value of https. If you do not use RemoteIpFilter in such a configuration, then the vulnerability would not have any impact on you Red Hat Satellite…
For possible impact and workaround, please refer to: https://access.redhat.com/solutions/7004796Source: Red Hat security advisory for CVE-2023-28708 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| JWS 5.7.4 release | jws5-tomcat | RHSA-2023:4910 |
| Red Hat Enterprise Linux 8 | tomcat-1:9.0.62-27.el8_9 | RHSA-2023:7065 |
| Red Hat Enterprise Linux 8.8 Extended Update Support | tomcat-1:9.0.87-1.el8_8.2 | RHSA-2024:3814 |
| Red Hat Enterprise Linux 9 | tomcat-1:9.0.62-37.el9_3 | RHSA-2023:6570 |
| Red Hat JBoss Web Server 5.7 on RHEL 7 | jws5-tomcat-0:9.0.62-15.redhat_00013.1.el7jws | RHSA-2023:4909 |
Frequently Asked Questions
Is CVE-2023-28708 in your dependencies?
Find it across Maven, including transitive dependencies.