NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2023-27159 — server-ce

HIGH

CVE-2023-27159 is a high-severity (CVSS 7.5) Server-Side Request Forgery (SSRF) vulnerability in appwrite/server-ce. 3 public exploit or proof-of-concept references are indexed, so weaponization risk is real. The records list no fixed version yet; check the vendor advisory below and apply the mitigations in the meantime.

Appwrite Server-Side Request Forgery vulnerability

Also known asGHSA-hxgx-584x-vwm8
Published
Updated
Affected
1 pkg
Patched
See advisory
Exploits
3 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-27159.

EPSS Exploitation Probability

via FIRST.org ↗
36.4%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs98th percentile — riskier than 98% of all scored CVEsHighest risk
22.9%46.5%70.0%93.5%80.2%36.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘appwrite/server-ce

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Appwrite up to v1.2.1 was discovered to contain a Server-Side Request Forgery (SSRF) via the component /v1/avatars/favicon. This vulnerability allows attackers to access network resources and sensitive information via a crafted GET request.

Affected Packages

1 total
EcosystemPackageVulnerable rangeFix
🐘Packagistappwrite/server-ceall versionsNo fix

Affected Products

1 product · 1 configurations
Application
appwriteappwrite
≤ 1.2.1
range
Exploits & PoCs
3

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for appwrite/server-ce, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Remediation status

    The records we use list no patched version of appwrite/server-ce for CVE-2023-27159. Check the maintainer's advisory, and where your build allows, override or pin the dependency away from the vulnerable range.

  3. Mitigate without a patch

    Restrict outbound requests from the affected component to an allowlist of hosts, block access to link-local and internal address ranges at the network layer, and require authentication on internal services so a forged request cannot reach them unauthenticated.

How to detect CVE-2023-27159

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2023-27159 -u https://target
Template
Appwrite <=1.2.1 - Server-Side Request Forgery
Severity
high
Impact
This vulnerability can lead to unauthorized access to internal resources, potential data leakage, and further exploitation of the server.
Remediation
Upgrade Appwrite to a version higher than 1.2.1 to mitigate the SSRF vulnerability.

Template by ProjectDiscovery nuclei-templates (DhiyaneshDk), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

Appwrite up to v1.2.1 was discovered to contain a Server-Side Request Forgery (SSRF) via the component /v1/avatars/favicon. This vulnerability allows attackers to access network resources and sensitive information via a crafted GET request.
O3 Security · Impact-Aware SCA

Is CVE-2023-27159 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2023-27159: server-ce SSRF (High 7.5)