NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
CRITICAL severity

CVE-2022-2925 — server-ce

CRITICALFix: appwrite/appwrite@b5b4d92

CVE-2022-2925 is a critical-severity (CVSS 9) Cross-site Scripting (XSS) vulnerability in appwrite/server-ce. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for appwrite/server-ce — see the affected versions and patch details below.

Cross-site Scripting (XSS) - Stored in appwrite/appwrite

Also known asGHSA-5ffj-mph5-c5hv
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk+0.02%
Lower risk than most CVEs58th percentile — riskier than 58% of all scored CVEsHighest risk
0.00%0.45%0.90%1.35%0.3%0.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘appwrite/server-ce

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Appwrite is vulnerable to stored cross-site scripting in usernames, function names, storage bucket names, and database collection names.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistappwrite/server-ceall versions1.0.0-RC1composer require appwrite/server-ce:^1.0.0-RC1

Affected Products

1 product · 1 configurations
Application
appwriteappwrite
≤ 0.15.3
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for appwrite/server-ce, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update appwrite/server-ce to 1.0.0-RC1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-2925 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Appwrite is vulnerable to stored cross-site scripting in usernames, function names, storage bucket names, and database collection names.
O3 Security · Impact-Aware SCA

Is CVE-2022-2925 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2022-2925: server-ce XSS — Fixed in 1.0.0-RC1