CVE-2021-23682 is a critical-severity (CVSS 9.8) CWE-1321 vulnerability in litespeed.js. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for litespeed.js — see the affected versions and patch details below.
Prototype Pollution in litespeed.js and appwrite/server-ce
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
litespeed.jsnpmDescription
This affects the package litespeed.js before 0.3.12; the package appwrite/server-ce from 0.12.0 and before 0.12.2, before 0.11.1. When parsing the query string in the getJsonFromUrl function, the key that is set in the result object is not properly sanitized leading to a Prototype Pollution vulnerability.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | litespeed.js | all versions | 0.3.12npm install litespeed.js@0.3.12 |
| 🐘Packagist | appwrite/server-ce | ≥ 0.12.0&&< 0.12.2 | 0.12.2composer require appwrite/server-ce:^0.12.2 |
| 🐘Packagist | appwrite/server-ce | all versions | 0.11.1composer require appwrite/server-ce:^0.11.1 |
Affected Products
appwriteappwritelitespeed.jslitespeed.js_projectResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for litespeed.js, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update litespeed.js to 0.3.12 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-23682 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2021-23682 in your dependencies?
Find it across npm, Packagist, including transitive dependencies.