CVE-2023-25577 is a high-severity (CVSS 7.5) CWE-770 vulnerability in werkzeug. A fix is available for werkzeug — see the affected versions and patch details below.
Werkzeug may allow high resource usage when parsing multipart form data with many fields
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-25577.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
werkzeugReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Werkzeug is a comprehensive WSGI web application library. Prior to version 2.2.3, Werkzeug's multipart form data parser will parse an unlimited number of parts, including file parts. Parts can be a small amount of bytes, but each requires CPU time to parse and may use more memory as Python data. If a request can be made to an endpoint that accesses request.data, request.form, request.files, or request.get_data(parse_form_data=False), it can cause unexpectedly high resource usage. This allows an attacker to cause a denial of service by sending crafted multipart data to an endpoint that will parse it. The amount of CPU time required can block worker processes from handling legitimate requests. The amount of RAM required can trigger an out of memory kill of the process. Unlimited file parts can use up memory and file handles. If many concurrent requests are sent continuously, this can exhaust or kill all available workers. Version 2.2.3 contains a patch for this issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | werkzeug | all versions | 2.2.3pip install --upgrade 'werkzeug==2.2.3' |
Affected Products
werkzeugpalletsprojectsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for werkzeug, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update werkzeug to 2.2.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-25577 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Ironic content for Red Hat OpenShift Container Platform 4.11 | python-werkzeug-0:2.0.3-5.el8 | RHBA-2023:1759 |
| Ironic content for Red Hat OpenShift Container Platform 4.12 | python-werkzeug-0:2.0.3-4.el9 | RHBA-2023:1507 |
| Ironic content for Red Hat OpenShift Container Platform 4.13 | python-werkzeug-0:2.0.3-4.el9 | RHSA-2023:1325 |
| Red Hat Ceph Storage 7.1 | oath-toolkit-0:2.6.12-1.el8cp | RHSA-2025:4664 |
| Red Hat Ceph Storage 8.1 | oath-toolkit-0:2.6.12-1.el9cp | RHSA-2025:9775 |
| Red Hat OpenShift Container Platform 4.14 | python-werkzeug-0:2.2.3-2.el9 | RHSA-2023:7473 |
| Red Hat OpenStack Platform 13.0 Octavia - ELS | python-werkzeug-0:0.14.1-3.1.el7ost | RHSA-2023:1281 |
| Red Hat OpenStack Platform 17.0 | python-werkzeug-0:2.0.1-5.el9ost | RHSA-2023:1018 |
Frequently Asked Questions
Is CVE-2023-25577 in your dependencies?
Find it across PyPI, including transitive dependencies.