NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
MEDIUM severity

CVE-2023-2515 — mattermost-server

MEDIUM

CVE-2023-2515 is a medium-severity (CVSS 4.7) CWE-863 vulnerability in github.com/mattermost/mattermost-server/v6. A fix is available for github.com/mattermost/mattermost-server/v6 — see the affected versions and patch details below.

Privilege escalation to system admin via personal access tokens

Also known asBIT-mattermost-2023-2515GHSA-7g2v-2frm-rg94
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-2515.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs41th percentile — riskier than 41% of all scored CVEsHighest risk
0.00%0.32%0.65%0.97%0.1%0.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐹github.com/mattermost/mattermost-server/v6🐹github.com/mattermost/mattermost-server/v6🐹github.com/mattermost/mattermost-server/v6🐹github.com/mattermost/mattermost-server/v6

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Mattermost fails to restrict a user with permissions to edit other users and to create personal access tokens from elevating their privileges to system admin

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/mattermost/mattermost-server/v6all versions7.1.8go get github.com/mattermost/mattermost-server/v6@v7.1.8
🐹Gogithub.com/mattermost/mattermost-server/v6≥ 7.2.0&&< 7.7.47.7.4go get github.com/mattermost/mattermost-server/v6@v7.7.4
🐹Gogithub.com/mattermost/mattermost-server/v6≥ 7.8.0&&< 7.8.37.8.3go get github.com/mattermost/mattermost-server/v6@v7.8.3
🐹Gogithub.com/mattermost/mattermost-server/v6≥ 7.9.0&&< 7.9.27.9.2go get github.com/mattermost/mattermost-server/v6@v7.9.2

Affected Products

1 product · 4 configurations
Application
mattermost servermattermost
≥ 7.9.0 && < 7.9.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/mattermost/mattermost-server/v6, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/mattermost/mattermost-server/v6 to 7.1.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-2515 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

Mattermost fails to restrict a user with permissions to edit other users and to create personal access tokens from elevating their privileges to system admin
O3 Security · Impact-Aware SCA

Is CVE-2023-2515 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2023-2515: mattermost-server — Fixed in 7.1.8