CVE-2023-22491 — gatsby-transformer-remark
HIGHCVE-2023-22491 is a high-severity (CVSS 8.1) Improper Input Validation vulnerability in gatsby-transformer-remark. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for gatsby-transformer-remark — see the affected versions and patch details below.
gatsby-transformer-remark vulnerable to unsanitized JavaScript code injection
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- A successful exploit gives an attacker total control of the affected component, not partial access.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-22491.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
gatsby-transformer-remarknpmDescription
Impact
The gatsby-transformer-remark plugin prior to versions 5.25.1 and 6.3.2 passes input through to the gray-matter npm package, which is vulnerable to JavaScript injection in its default configuration, unless input is sanitized. The vulnerability is present in gatsby-transformer-remark when passing input in data mode (querying MarkdownRemark nodes via GraphQL). Injected JavaScript executes in the context of the build server.
To exploit this vulnerability untrusted/unsanitized input would need to be sourced by or added into a file processed by gatsby-transformer-remark. The following payload demonstrates a vulnerable configuration:
---js
((require("child_process")).execSync("id >> /tmp/rce"))
---
Patches
A patch has been introduced in [email protected] and [email protected] which mitigates the issue by disabling the gray-matter JavaScript Frontmatter engine. The patch introduces a new option, JSFrontmatterEngine which is set to false by default. When setting JSFrontmatterEngine to true, input passed to gatsby-plugin-mdx must be sanitized before processing to avoid a security risk. Warnings are displayed when enabling JSFrontmatterEngine to true or if it appears that the MarkdownRemark input is attempting to use the Frontmatter engine.
Workarounds
If an older version of gatsby-transformer-remark must be used, input passed into the plugin should be sanitized ahead of processing.
We encourage projects to upgrade to the latest major release branch for all Gatsby plugins to ensure the latest security updates and bug fixes are received in a timely manner.
For more information
Email us at [email protected].
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | gatsby-transformer-remark | ≥ 6.0.0&&< 6.3.2 | 6.3.2npm install gatsby-transformer-remark@6.3.2 |
| 📦npm | gatsby-transformer-remark | all versions | 5.25.1npm install gatsby-transformer-remark@5.25.1 |
Affected Products
gatsby-transformer-remarkgatsbyjsResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for gatsby-transformer-remark, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update gatsby-transformer-remark to 6.3.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-22491 is resolved across your whole dependency graph.
Workarounds
Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.
Frequently Asked Questions
Is CVE-2023-22491 in your dependencies?
Find it across npm, including transitive dependencies.