NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
MEDIUM severity

CVE-2023-1777 — mattermost-server

MEDIUM

CVE-2023-1777 is a medium-severity (CVSS 6.5) Information Exposure vulnerability in github.com/mattermost/mattermost-server/v6. A fix is available for github.com/mattermost/mattermost-server/v6 — see the affected versions and patch details below.

Information disclosure in linked message previews

Also known asBIT-mattermost-2023-1777GHSA-3wq5-3f56-v5xc
Published
Updated
Affected
6 pkgs
Patched
6 / 6
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-1777.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs45th percentile — riskier than 45% of all scored CVEsHighest risk
0.00%0.35%0.69%1.04%0.3%0.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

6 pkgs affected
🐹github.com/mattermost/mattermost-server/v6🐹github.com/mattermost/mattermost-server🐹github.com/mattermost/mattermost-server🐹github.com/mattermost/mattermost-server🐹github.com/mattermost/mattermost-server/v6🐹github.com/mattermost/mattermost-server

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Mattermost allows an attacker to request a preview of an existing message when creating a new message via the createPost API call, disclosing the contents of the linked message.

Affected Packages

6 total 6 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/mattermost/mattermost-server/v6≥ 6.3.0&&< 7.1.67.1.6go get github.com/mattermost/mattermost-server/v6@v7.1.6
🐹Gogithub.com/mattermost/mattermost-server≥ 7.8.0&&< 7.8.17.8.1go get github.com/mattermost/mattermost-server@v7.8.1
🐹Gogithub.com/mattermost/mattermost-server≥ 7.7.0&&< 7.7.27.7.2go get github.com/mattermost/mattermost-server@v7.7.2
🐹Gogithub.com/mattermost/mattermost-server≥ 7.1.0&&< 7.1.67.1.6go get github.com/mattermost/mattermost-server@v7.1.6
🐹Gogithub.com/mattermost/mattermost-server/v6≥ 6.0.0-20211025164829-f7a8147b825c&&< 6.0.0-20230301145909-10be118d99a56.0.0-20230301145909-10be118d99a5go get github.com/mattermost/mattermost-server/v6@v6.0.0-20230301145909-10be118d99a5
🐹Gogithub.com/mattermost/mattermost-server≥ 1.4.1-0.20211025164829-f7a8147b825c&&< 1.4.1-0.20230301145909-10be118d99a51.4.1-0.20230301145909-10be118d99a5go get github.com/mattermost/mattermost-server@v1.4.1-0.20230301145909-10be118d99a5

Affected Products

1 product · 3 configurations
Application
mattermost servermattermost
< 7.1.6
2 versions
7.7.17.8.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/mattermost/mattermost-server/v6, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/mattermost/mattermost-server/v6 to 7.1.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-1777 is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Frequently Asked Questions

Mattermost allows an attacker to request a preview of an existing message when creating a new message via the createPost API call, disclosing the contents of the linked message.
O3 Security · Impact-Aware SCA

Is CVE-2023-1777 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2023-1777: mattermost-server — Fixed in 7.1.6