NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
HIGH severity

CVE-2023-1776 — mattermost-server

HIGH

CVE-2023-1776 is a high-severity (CVSS 7.3) Cross-site Scripting (XSS) vulnerability in github.com/mattermost/mattermost-server/v6. A fix is available for github.com/mattermost/mattermost-server/v6 — see the affected versions and patch details below.

Stored XSS via SVG attachment on Boards

Also known asBIT-mattermost-2023-1776GHSA-63f2-6959-2pxj
Published
Updated
Affected
6 pkgs
Patched
6 / 6
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-1776.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs39th percentile — riskier than 39% of all scored CVEsHighest risk
0.00%0.40%0.81%1.21%0.7%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

6 pkgs affected
🐹github.com/mattermost/mattermost-server/v6🐹github.com/mattermost/mattermost-server🐹github.com/mattermost/mattermost-server🐹github.com/mattermost/mattermost-server🐹github.com/mattermost/mattermost-server/v5🐹github.com/mattermost/mattermost-server/v6

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Boards in Mattermost allows an attacker to upload a malicious SVG image file as an attachment to a card and share it using a direct link to the file.

Issue Identifier: MMSA-2023-00139

Affected Packages

6 total 6 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/mattermost/mattermost-server/v6≥ 6.0.0&&< 7.1.67.1.6go get github.com/mattermost/mattermost-server/v6@v7.1.6
🐹Gogithub.com/mattermost/mattermost-server≥ 7.7.0&&< 7.7.27.7.2go get github.com/mattermost/mattermost-server@v7.7.2
🐹Gogithub.com/mattermost/mattermost-server≥ 7.1.0&&< 7.1.67.1.6go get github.com/mattermost/mattermost-server@v7.1.6
🐹Gogithub.com/mattermost/mattermost-server≥ 7.8.0&&< 7.8.17.8.1go get github.com/mattermost/mattermost-server@v7.8.1
🐹Gogithub.com/mattermost/mattermost-server/v5≥ 5.0.0&&< 7.1.67.1.6go get github.com/mattermost/mattermost-server/v5@v7.1.6
🐹Gogithub.com/mattermost/mattermost-server/v6≥ 3.3.0&&< 7.1.67.1.6go get github.com/mattermost/mattermost-server/v6@v7.1.6

Affected Products

1 product · 2 configurations
Application
mattermost servermattermost
< 7.1.6
1 version
7.7.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/mattermost/mattermost-server/v6, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/mattermost/mattermost-server/v6 to 7.1.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-1776 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Boards in Mattermost allows an attacker to upload a malicious SVG image file as an attachment to a card and share it using a direct link to the file. [Issue Identifier](https://mattermost.com/security-updates/): MMSA-2023-00139
O3 Security · Impact-Aware SCA

Is CVE-2023-1776 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2023-1776: mattermost-server — Fixed in 7.1.6