NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2022-42119 — com.liferay.commerce.cata…

MEDIUMFix: liferay/liferay-portal@2e02110

CVE-2022-42119 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in com.liferay.commerce:com.liferay.commerce.catalog.web. A fix is available for com.liferay.commerce:com.liferay.commerce.catalog.web — see the affected versions and patch details below.

Liferay Portal and Liferay DXP Vulnerable to XSS via the Commerce Module

Also known asGHSA-wjfm-qxg2-q679
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-42119.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs38th percentile — riskier than 38% of all scored CVEsHighest risk
0.00%0.38%0.76%1.14%0.6%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕com.liferay.commerce:com.liferay.commerce.catalog.web☕com.liferay.portal:release.dxp.bom

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Certain Liferay products are vulnerable to Cross Site Scripting (XSS) via the Commerce module. This affects the Commerce module before 4.0.8 from Liferay Portal (7.3.5 through 7.4.2) and Liferay DXP 7.3 before update 8.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavencom.liferay.commerce:com.liferay.commerce.catalog.weball versions4.0.8com.liferay.commerce:com.liferay.commerce.catalog.web:4.0.8
☕Mavencom.liferay.portal:release.dxp.bom≥ 7.3.0&&< 7.3.10.u87.3.10.u8com.liferay.portal:release.dxp.bom:7.3.10.u8

Affected Products

2 products · 9 configurations
Application
dxpliferay
1 version
7.3
Application
liferay portalliferay
≥ 7.3.5 && ≤ 7.4.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.liferay.commerce:com.liferay.commerce.catalog.web, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update com.liferay.commerce:com.liferay.commerce.catalog.web to 4.0.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-42119 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Certain Liferay products are vulnerable to Cross Site Scripting (XSS) via the Commerce module. This affects the Commerce module before 4.0.8 from Liferay Portal (7.3.5 through 7.4.2) and Liferay DXP 7.3 before update 8.
O3 Security · Impact-Aware SCA

Is CVE-2022-42119 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2022-42119: com.liferay.commerce — Fixed in 4.0.8