NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2022-42114 — com.liferay.roles.admin.w…

MEDIUMFix: liferay/liferay-portal@ba9a07e

CVE-2022-42114 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in com.liferay:com.liferay.roles.admin.web. A fix is available for com.liferay:com.liferay.roles.admin.web — see the affected versions and patch details below.

Liferay Portal and Liferay DXP Vulnerable to XSS via the Role Module

Also known asGHSA-cmrw-cgfc-v6x2
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-42114.

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk+0.06%
Lower risk than most CVEs48th percentile — riskier than 48% of all scored CVEsHighest risk
0.00%0.36%0.73%1.09%0.2%0.6%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕com.liferay:com.liferay.roles.admin.web☕com.liferay.portal:release.dxp.bom

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

A Cross-site scripting (XSS) vulnerability in the Role module's edit role assignees page in Liferay Roles Admin Web before 5.0.48 from Liferay Portal (7.4.0 through 7.4.3.36), and Liferay DXP 7.4 before update 37 allows remote attackers to inject arbitrary web script or HTML.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavencom.liferay:com.liferay.roles.admin.weball versions5.0.48com.liferay:com.liferay.roles.admin.web:5.0.48
☕Mavencom.liferay.portal:release.dxp.bom≥ 7.4.0&&< 7.4.13.u377.4.13.u37com.liferay.portal:release.dxp.bom:7.4.13.u37

Affected Products

2 products · 39 configurations
Application
dxpliferay
< 7.4
1 version
7.4
Application
liferay portalliferay
≥ 7.4.0 && < 7.4.3.37
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.liferay:com.liferay.roles.admin.web, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update com.liferay:com.liferay.roles.admin.web to 5.0.48 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-42114 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

A Cross-site scripting (XSS) vulnerability in the Role module's edit role assignees page in Liferay Roles Admin Web before 5.0.48 from Liferay Portal (7.4.0 through 7.4.3.36), and Liferay DXP 7.4 before update 37 allows remote attackers to inject arbitrary web script or HTML.
O3 Security · Impact-Aware SCA

Is CVE-2022-42114 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2022-42114: com.liferay.roles.admin — Fixed in 5.0.48