NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2022-42110 — com.liferay.announcements…

MEDIUMFix: liferay/liferay-portal@99b1c47

CVE-2022-42110 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in com.liferay:com.liferay.announcements.web. A fix is available for com.liferay:com.liferay.announcements.web — see the affected versions and patch details below.

Liferay Portal and Liferay DXP Vulnerable to XSS via the Announcements Module

Also known asGHSA-2qwm-9mg5-jwq8
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-42110.

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk+0.03%
Lower risk than most CVEs50th percentile — riskier than 50% of all scored CVEsHighest risk
0.00%0.38%0.75%1.13%0.5%0.6%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
☕com.liferay:com.liferay.announcements.web☕com.liferay.portal:release.dxp.bom☕com.liferay.portal:release.dxp.bom

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

A Cross-site scripting (XSS) vulnerability in the Announcements module before 6.0.11 from Liferay Portal (7.1.0 through 7.4.2), and Liferay DXP 7.1 before fix pack 27, 7.2 before fix pack 17, and 7.3 before service pack 3 allows remote attackers to inject arbitrary web script or HTML.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
☕Mavencom.liferay:com.liferay.announcements.weball versions6.0.11com.liferay:com.liferay.announcements.web:6.0.11
☕Mavencom.liferay.portal:release.dxp.bom≥ 7.1.0&&< 7.1.10.fp277.1.10.fp27com.liferay.portal:release.dxp.bom:7.1.10.fp27
☕Mavencom.liferay.portal:release.dxp.bom≥ 7.2.0&&< 7.2.10.fp177.2.10.fp17com.liferay.portal:release.dxp.bom:7.2.10.fp17

Affected Products

3 products · 46 configurations
Application
digital experience platformliferay
2 versions
7.17.2
Application
dxpliferay
1 version
7.3
Application
liferay portalliferay
≥ 7.1.0 && ≤ 7.4.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.liferay:com.liferay.announcements.web, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update com.liferay:com.liferay.announcements.web to 6.0.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-42110 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

A Cross-site scripting (XSS) vulnerability in the Announcements module before 6.0.11 from Liferay Portal (7.1.0 through 7.4.2), and Liferay DXP 7.1 before fix pack 27, 7.2 before fix pack 17, and 7.3 before service pack 3 allows remote attackers to inject arbitrary web script or HTML.
O3 Security · Impact-Aware SCA

Is CVE-2022-42110 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2022-42110: com.liferay XSS — Fixed in 6.0.11