NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
CRITICAL severity

CVE-2022-37601 — loader-utils

CRITICALFix: webpack/loader-utils#217

CVE-2022-37601 is a critical-severity (CVSS 9.8) CWE-1321 vulnerability in loader-utils. 4 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for loader-utils — see the affected versions and patch details below.

Prototype pollution in webpack loader-utils

Also known asGHSA-76p3-8jx3-jpfq
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
4 known
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-37601.

EPSS Exploitation Probability

via FIRST.org ↗
3.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs89th percentile — riskier than 89% of all scored CVEsHighest risk
0.00%8.44%16.9%25.3%20.1%3.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

7Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
loader-utilsnpm
70.5Mdownloads / week

Description

Prototype pollution vulnerability in function parseQuery in parseQuery.js in webpack loader-utils via the name variable in parseQuery.js. This affects all versions prior to 1.4.1 and 2.0.3.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
📦npmloader-utils≥ 2.0.0&&< 2.0.32.0.3npm install loader-utils@2.0.3
📦npmloader-utilsall versions1.4.1npm install loader-utils@1.4.1

Affected Products

2 products · 3 configurations
OS
debian linuxdebian
1 version
10.0
Application
loader-utilswebpack.js
≥ 2.0.0 && < 2.0.3
range
Exploits & PoCs
4

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for loader-utils, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update loader-utils to 2.0.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-37601 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant

Packages shipped in Red Hat Enterprise Linux use 'loader-utils' as a transitive dependency. Thus, reducing the impact to Moderate. In Red Hat containerized products like OCP and ODF, the vulnerable loader-utils NodeJS module is bundled as a transitive dependency, hence the direct impact is reduced to Moderate.

ProductFixed inAdvisory
MTA-6.0-RHEL-8mta/mta-ui-rhel8:6.0.1-10RHSA-2023:0934
RHOL-5.6-RHEL-8openshift-logging/logging-view-plugin-rhel8:v5.6.0-28RHSA-2023:0264

Frequently Asked Questions

Prototype pollution vulnerability in function parseQuery in parseQuery.js in webpack loader-utils via the name variable in parseQuery.js. This affects all versions prior to 1.4.1 and 2.0.3.
O3 Security · Impact-Aware SCA

Is CVE-2022-37601 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2022-37601: loader-utils — Fixed in 2.0.3