CVE-2022-37599 is a high-severity (CVSS 7.5) CWE-1333 vulnerability in loader-utils. A fix is available for loader-utils — see the affected versions and patch details below.
loader-utils is vulnerable to Regular Expression Denial of Service (ReDoS)
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
loader-utilsnpmDescription
A regular expression denial of service (ReDoS) flaw was found in Function interpolateName in interpolateName.js in webpack loader-utils via the resourcePath variable in interpolateName.js. A badly or maliciously formed string could be used to send crafted requests that cause a system to crash or take a disproportional amount of time to process. This issue has been patched in versions 1.4.2, 2.0.4 and 3.2.1.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | loader-utils | ≥ 1.0.0&&< 1.4.2 | 1.4.2npm install loader-utils@1.4.2 |
| 📦npm | loader-utils | ≥ 2.0.0&&< 2.0.4 | 2.0.4npm install loader-utils@2.0.4 |
| 📦npm | loader-utils | ≥ 3.0.0&&< 3.2.1 | 3.2.1npm install loader-utils@3.2.1 |
Affected Products
loader-utilswebpack.jsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for loader-utils, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update loader-utils to 1.4.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-37599 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
In Red Hat OpenShift Logging the openshift-logging/kibana6-rhel8 container and openshift-logging/logging-view-plugin-rhel8 bundles many nodejs packages as a build time dependencies, including loader-utils package. The vulnerable code is not used hence the impact to OpenShift Logging by this vulnerability is Low.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability.Source: Red Hat security advisory for CVE-2022-37599 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| RHPAM 7.13.4 async | loader-utils | RHSA-2023:4983 |
Frequently Asked Questions
Is CVE-2022-37599 in your dependencies?
Find it across npm, including transitive dependencies.