NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
HIGH severity

CVE-2022-36085 — opa

HIGHFix: open-policy-agent/opa@25a597b

CVE-2022-36085 is a high-severity (CVSS 7.4) Improper Input Validation vulnerability in github.com/open-policy-agent/opa. 3 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for github.com/open-policy-agent/opa — see the affected versions and patch details below.

OPA Compiler: Bypass of WithUnsafeBuiltins using `with` keyword to mock functions

Also known asGHSA-f524-rf33-2jjrGO-2022-0978
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
3 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-36085.

EPSS Exploitation Probability

via FIRST.org ↗
1.6%probability of exploitation in next 30 days
Lower Risk+0.03%
Lower risk than most CVEs76th percentile — riskier than 76% of all scored CVEsHighest risk
0.72%1.19%1.66%2.13%1.4%1.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐹github.com/open-policy-agent/opa

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Impact

The Rego compiler provides a (deprecated) WithUnsafeBuiltins function, which allows users to provide a set of built-in functions that should be deemed unsafe — and as such rejected — by the compiler if encountered in the policy compilation stage. A bypass of this protection has been found, where the use of the with keyword to mock such a built-in function (a feature introduced in OPA v0.40.0), isn’t taken into account by WithUnsafeBuiltins.

The same method is exposed via rego.UnsafeBuiltins in the github.com/open-policy-agent/opa/rego package.

When provided e.g. the http.send built-in function to WithUnsafeBuiltins, the following policy would still compile, and call the http.send function with the arguments provided to the is_object function when evaluated:

package policy

foo := is_object({
    "method": "get", 
    "url": "https://www.openpolicyagent.org"
})

allow := r {
    r := foo with is_object as http.send
}

Both built-in functions and user provided (i.e. custom) functions are mockable using this construct.

In addition to http.send, the opa.runtime built-in function is commonly considered unsafe in integrations where policy provided by untrusted parties is evaluated, as it risks exposing configuration, or environment variables, potentially carrying sensitive information.

Affected Users

All of these conditions have to be met to create an adverse effect:

  • Use the Go API for policy evaluation (not the OPA server, or the Go SDK)
  • Make use of the WithUnsafeBuiltins method in order to deny certain built-in functions, like e.g. http.send, from being used in policy evaluation.
  • Allow policy evaluation of policies provided by untrusted parties.
  • The policies evaluated include the with keyword to rewrite/mock a built-in, or custom, function to that of another built-in function, such as http.send.

Additionally, the OPA Query API is affected:

  • If the OPA Query API is exposed to the public, and it is relied on http.send to be unavailable in that context. Exposing the OPA API to the public without proper authentication and authorization in place is generally advised against.

Patches

v0.43.1, v0.44.0

Workarounds

The WithUnsafeBuiltins function has been considered deprecated since the introduction of the capabilities feature in OPA v0.23.0 . While the function was commented as deprecated, the format of the comment was however not following the convention for deprecated functions, and might not have been picked up by tooling like editors. This has now been fixed. Users are still encouraged to use the capabilities feature over the deprecated WithUnsafeBuiltins function.

If you cannot upgrade, consider using capabilities instead:

Code like this using the github.com/open-policy-agent/opa/ast package:

// VULNERABLE with OPA <= 0.43.0
unsafeBuiltins := map[string]struct{}{
	ast.HTTPSend.Name: struct{}{},
}
compiler := ast.NewCompiler().WithUnsafeBuiltins(unsafeBuiltins)

needs to be changed to this:

caps := ast.CapabilitiesForThisVersion()
var j int
for i, bi := range caps.Builtins {
	if bi.Name == ast.HTTPSend.Name {
		j = i
		break
	}
}
caps.Builtins[j] = caps.Builtins[len(caps.Builtins)-1] // put last element into position j
caps.Builtins = caps.Builtins[:len(caps.Builtins)-1]   // truncate slice

compiler := ast.NewCompiler().WithCapabilities(caps)

When using the github.com/open-policy-agent/opa/rego package:

// VULNERABLE with OPA <= 0.43.0
r := rego.New(
	// other options omitted
	rego.UnsafeBuiltins(map[string]struct{}{ast.HTTPSend.Name: struct{}{}}),
)

needs to be changed to

r := rego.New(
	// other options omitted
	rego.Capabilities(caps),
)

with caps defined above.

Note that in the process, some error messages will change: http.send in this example will no longer be "unsafe" and thus forbidden, but it will simply become an "unknown function".

References

For more information

If you have any questions or comments about this advisory:

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/open-policy-agent/opa≥ 0.40.0&&< 0.43.10.43.1go get github.com/open-policy-agent/opa@v0.43.1

Affected Products

1 product · 1 configurations
Application
open policy agentopenpolicyagent
≥ 0.40.0 && < 0.43.1
range
Exploits & PoCs
3

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/open-policy-agent/opa, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/open-policy-agent/opa to 0.43.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-36085 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Impact The Rego compiler provides a (deprecated) `WithUnsafeBuiltins` function, which allows users to provide a set of built-in functions that should be deemed unsafe — and as such rejected — by the compiler if encountered in the policy compilation stage. A bypass of this protection has been found, where the use of the `with` keyword to mock such a built-in function (a feature introduced in OPA v0.40.0), isn’t taken into account by `WithUnsafeBuiltins`. The same method is exposed via `rego.UnsafeBuiltins` in the `github.com/open-policy-agent/opa/rego` package. When provided e.g. the `ht
O3 Security · Impact-Aware SCA

Is CVE-2022-36085 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2022-36085: opa — Fixed in 0.43.1