NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
HIGH severity

CVE-2022-33082 — opa

HIGHFix: open-policy-agent/opa#4701

CVE-2022-33082 is a high-severity (CVSS 7.5) vulnerability in github.com/open-policy-agent/opa. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for github.com/open-policy-agent/opa — see the affected versions and patch details below.

Denial of service in Open Policy Agent

Also known asGHSA-2m4x-4q9j-w97gGO-2022-0574
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs78th percentile — riskier than 78% of all scored CVEsHighest risk
0.59%1.14%1.70%2.25%1.1%1.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐹github.com/open-policy-agent/opa

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

An issue in the AST parser (ast/compile.go) of Open Policy Agent v0.10.2 allows attackers to cause a Denial of Service (DoS) via a crafted input.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/open-policy-agent/opaall versions0.42.0go get github.com/open-policy-agent/opa@v0.42.0

Affected Products

1 product · 1 configurations
Application
open policy agentopenpolicyagent
< 0.42.0
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/open-policy-agent/opa, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/open-policy-agent/opa to 0.42.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-33082 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

An issue in the AST parser (ast/compile.go) of Open Policy Agent v0.10.2 allows attackers to cause a Denial of Service (DoS) via a crafted input.
O3 Security · Impact-Aware SCA

Is CVE-2022-33082 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2022-33082: opa DoS — Fixed in 0.42.0