NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2022-35278 — artemis-server

MEDIUM

CVE-2022-35278 is a medium-severity (CVSS 6.1) CWE-80 vulnerability in org.apache.activemq:artemis-server. A fix is available for org.apache.activemq:artemis-server — see the affected versions and patch details below.

HTML Injection in ActiveMQ Artemis Web Console

Also known asGHSA-cv6r-h2fm-pvrp
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs78th percentile — riskier than 78% of all scored CVEsHighest risk
0.00%3.27%6.53%9.80%7.9%1.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.apache.activemq:artemis-server

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

In Apache ActiveMQ Artemis prior to 2.24.0, an attacker could show malicious content and/or redirect users to a malicious URL in the web console by using HTML in the name of an address or queue.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.activemq:artemis-serverall versions2.24.0org.apache.activemq:artemis-server:2.24.0

Affected Products

3 products · 3 configurations
Application
artemisapache
< 2.24.0
range
Application
active iq unified managernetapp
all
Application
oncommand workflow automationnetapp
all

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.activemq:artemis-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.activemq:artemis-server to 2.24.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-35278 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant
ProductFixed inAdvisory
AMQ Broker 7.10.1artemis-pluginRHSA-2022:6916
Red Hat AMQ 7.8.7see advisoryRHSA-2022:6292

Frequently Asked Questions

In Apache ActiveMQ Artemis prior to 2.24.0, an attacker could show malicious content and/or redirect users to a malicious URL in the web console by using HTML in the name of an address or queue.
O3 Security · Impact-Aware SCA

Is CVE-2022-35278 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2022-35278: artemis-server — Fixed in 2.24.0