CVE-2026-27446 — artemis-server
CVE-2026-27446 is a Missing Authentication vulnerability in org.apache.activemq:artemis-server. EPSS puts its 30-day exploitation probability at 11.4% (96th percentile). A fix is available for org.apache.activemq:artemis-server — see the affected versions and patch details below.
Apache Artemis, Apache ActiveMQ Artemis: Auth bypass for Core downstream federation
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-27446.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.apache.activemq:artemis-server☕org.apache.artemis:artemis-serverReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Missing Authentication for Critical Function (CWE-306) vulnerability in Apache Artemis, Apache ActiveMQ Artemis. An unauthenticated remote attacker can use the Core protocol to force a target broker to establish an outbound Core federation connection to an attacker-controlled rogue broker. This could potentially result in message injection into any queue and/or message exfiltration from any queue via the rogue broker. This impacts environments that allow both:
-
incoming Core protocol connections from untrusted sources to the broker
-
outgoing Core protocol connections from the broker to untrusted targets
This issue affects:
-
Apache Artemis from 2.50.0 through 2.51.0
-
Apache ActiveMQ Artemis from 2.11.0 through 2.44.0.
Users are recommended to upgrade to Apache Artemis version 2.52.0, which fixes the issue.
The issue can be mitigated by one of the following:
-
Remove Core protocol support from any acceptor receiving connections from untrusted sources. Incoming Core protocol connections are supported by default via the "artemis" acceptor listening on port 61616. See the "protocols" URL parameter configured for the acceptor. An acceptor URL without this parameter supports all protocols by default, including Core.
-
Use two-way SSL (i.e. certificate-based authentication) in order to force every client to present the proper SSL certificate when establishing a connection before any message protocol handshake is attempted. This will prevent unauthenticated exploitation of this vulnerability.
-
Implement and deploy a Core interceptor to deny all Core downstream federation connect packets. Such packets have a type of (int) -16 or (byte) 0xfffffff0. Documentation for interceptors is available at https://artemis.apache.org/components/artemis/documentation/latest/intercepting-operations.html .
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.activemq:artemis-server | ≥ 2.11.0 | No fix |
| ☕Maven | org.apache.artemis:artemis-server | ≥ 2.50.0&&< 2.52.0 | 2.52.0org.apache.artemis:artemis-server:2.52.0 |
Affected Products
artemisapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.activemq:artemis-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
A fix is available for CVE-2026-27446; check the affected-versions list above or the advisory for the patched release of org.apache.activemq:artemis-server, then make sure no transitive dependency still pins the vulnerable range.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Red Hat rates this flaw as IMPORTANT severity because it does not enable remote code execution or system compromise (arbitrary code execution), which is Red Hat's threshold for Critical impact. Its impact is limited to message injection and exfiltration via rogue broker federation. Exploitation requires the broker to…
To mitigate this issue, restrict Core protocol support on acceptors receiving connections from untrusted sources. The default "artemis" acceptor on port 61616 supports all protocols, including Core. Modify the acceptor URL to explicitly exclude the Core protocol using the "protocols" URL parameter. Alternatively, configure two-way SSL with certificate-based authentication to prevent unauthenticated exploitation. A service restart or reload may be required for changes to take effect.Source: Red Hat security advisory for CVE-2026-27446 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat AMQ Broker 7.12.6 | artemis-server | RHSA-2026:3955 |
| Red Hat AMQ Broker 7.13.4 | artemis-server | RHSA-2026:3957 |
| Red Hat build of Apache Camel 4.18.1 for Spring Boot 3.5.14 | artemis-server | RHSA-2026:17668 |
| Red Hat JBoss Enterprise Application Platform 7.4.25 | artemis-server | RHSA-2026:53806 |
| Red Hat JBoss Enterprise Application Platform 7.4 ELS on RHEL 7 | eap7-activemq-artemis-0:2.16.0-22.redhat_00057.1.el7eap | RHSA-2026:53644 |
| Red Hat JBoss Enterprise Application Platform 8.1.6.GA | org.apache.activemq/artemis-server:2.40.0.redhat-00012 | RHSA-2026:18059 |
| Red Hat JBoss Enterprise Application Platform 8.1 for RHEL 8 | eap8-activemq-artemis-0:2.40.0-6.redhat_00012.1.el8eap | RHSA-2026:18054 |
| Red Hat JBoss Enterprise Application Platform 8.1 for RHEL 9 | eap8-activemq-artemis-0:2.40.0-6.redhat_00012.1.el9eap | RHSA-2026:18055 |
Frequently Asked Questions
Is CVE-2026-27446 in your dependencies?
Find it across Maven, including transitive dependencies.