NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2022-34169 — xalan

HIGH

CVE-2022-34169 is a high-severity (CVSS 7.5) CWE-681 vulnerability in xalan:xalan. 3 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for xalan:xalan — see the affected versions and patch details below.

Apache Xalan Java XSLT library is vulnerable to an integer truncation issue when processing malicious XSLT stylesheets

Also known asBIT-java-2022-34169BIT-java-min-2022-34169BIT-jre-2022-34169GHSA-9339-86wc-4qgf
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
3 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-34169.

EPSS Exploitation Probability

via FIRST.org ↗
81.8%probability of exploitation in next 30 days
Very High Risk0.00%
Lower risk than most CVEs100th percentile — riskier than 100% of all scored CVEsHighest risk
0.00%33.3%66.7%100.0%6.7%81.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕xalan:xalan

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

The Apache Xalan Java XSLT library is vulnerable to an integer truncation issue when processing malicious XSLT stylesheets. This can be used to corrupt Java class files generated by the internal XSLTC compiler and execute arbitrary Java bytecode. Users are recommended to update to version 2.7.3 or later. Note: Java runtimes (such as OpenJDK) include repackaged copies of Xalan.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenxalan:xalanall versions2.7.3xalan:xalan:2.7.3

Affected Products

16 products · 159 configurations
Application
xalan-javaapache
≤ 2.7.2
range
Application
zuluazul
8 versions
6.477.548.6211.5613.4815.4017.3418.30
OS
debian linuxdebian
2 versions
10.011.0
OS
fedorafedoraproject
2 versions
3536
Application
7-mode transition toolnetapp
all
Application
active iq unified managernetapp
all
Exploits & PoCs
3

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for xalan:xalan, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update xalan:xalan to 2.7.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-34169 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant
ProductFixed inAdvisory
Red Hat build of Apache Camel 3.20.6 for Spring BootxalanRHSA-2024:3708
Red Hat Build of OpenJDK 11.0.16LinuxRHSA-2022:5755
Red Hat Build of OpenJDK 11.0.16WindowsRHSA-2022:5756
Red Hat Build of OpenJDK 17.0.4LinuxRHSA-2022:5758
Red Hat Build of OpenJDK 17.0.4WindowsRHSA-2022:5757
Red Hat Build of OpenJDK 8u342LinuxRHSA-2022:5754
Red Hat Build of OpenJDK 8u342WindowsRHSA-2022:5753
Red Hat Enterprise Linux 7java-11-openjdk-1:11.0.16.0.8-1.el7_9RHSA-2022:5687

Frequently Asked Questions

The Apache Xalan Java XSLT library is vulnerable to an integer truncation issue when processing malicious XSLT stylesheets. This can be used to corrupt Java class files generated by the internal XSLTC compiler and execute arbitrary Java bytecode. Users are recommended to update to version 2.7.3 or later. Note: Java runtimes (such as OpenJDK) include repackaged copies of Xalan.
O3 Security · Impact-Aware SCA

Is CVE-2022-34169 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2022-34169: xalan — Fixed in 2.7.3