CVE-2014-0107 — xalan
CVE-2014-0107 is a CWE-264 vulnerability in xalan:xalan. EPSS puts its 30-day exploitation probability at 14.1% (97th percentile). A fix is available for xalan:xalan — see the affected versions and patch details below.
Improper Authorization in Apache Xalan-Java
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
xalan:xalanReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
The TransformerFactory in Apache Xalan-Java before 2.7.2 does not properly restrict access to certain properties when FEATURE_SECURE_PROCESSING is enabled, which allows remote attackers to bypass expected restrictions and load arbitrary classes or access external resources via a crafted (1) xalan:content-header, (2) xalan:entities, (3) xslt:content-header, or (4) xslt:entities property, or a Java property that is bound to the XSLT 1.0 system-property function.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | xalan:xalan | all versions | 2.7.2xalan:xalan:2.7.2 |
Affected Products
xalan-javaapachewebcenter sitesoracleDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for xalan:xalan, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update xalan:xalan to 2.7.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-0107 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Fuse ESB Enterprise 7.1.0 | see advisory | RHSA-2014:1369 |
| JBoss Enterprise BRMS Platform 5.3 | xalan-j2 | RHSA-2014:1007 |
| Red Hat Enterprise Linux 5 | xalan-j2-0:2.7.0-6jpp.2 | RHSA-2014:0348 |
| Red Hat JBoss A-MQ 6.1 | see advisory | RHSA-2014:1351 |
| Red Hat JBoss BPMS 6.0 | see advisory | RHSA-2014:0819 |
| Red Hat JBoss BPMS 6.0 | xalan-j2 | RHSA-2014:1291 |
| Red Hat JBoss BRMS 6.0 | see advisory | RHSA-2014:0818 |
| Red Hat JBoss BRMS 6.0 | xalan-j2 | RHSA-2014:1290 |
Frequently Asked Questions
Is CVE-2014-0107 in your dependencies?
Find it across Maven, including transitive dependencies.