NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
MEDIUM severity

CVE-2022-3294 — kubernetes

MEDIUM

CVE-2022-3294 is a medium-severity (CVSS 6.6) Improper Input Validation vulnerability in github.com/kubernetes/kubernetes. A fix is available for github.com/kubernetes/kubernetes — see the affected versions and patch details below.

Node address isn't always verified when proxying

Also known asGHSA-jh36-q97c-9928GO-2023-1629
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-3294.

EPSS Exploitation Probability

via FIRST.org ↗
1.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs76th percentile — riskier than 76% of all scored CVEsHighest risk
0.01%0.71%1.42%2.12%0.5%1.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐹github.com/kubernetes/kubernetes🐹github.com/kubernetes/kubernetes🐹github.com/kubernetes/kubernetes🐹github.com/kubernetes/kubernetes

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Users may have access to secure endpoints in the control plane network. Kubernetes clusters are only affected if an untrusted user can modify Node objects and send proxy requests to them. Kubernetes supports node proxying, which allows clients of kube-apiserver to access endpoints of a Kubelet to establish connections to Pods, retrieve container logs, and more. While Kubernetes already validates the proxying address for Nodes, a bug in kube-apiserver made it possible to bypass this validation. Bypassing this validation could allow authenticated requests destined for Nodes to to the API server's private network.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/kubernetes/kubernetes≥ 1.25.0&&< 1.25.41.25.4go get github.com/kubernetes/kubernetes@v1.25.4
🐹Gogithub.com/kubernetes/kubernetes≥ 1.24.0&&< 1.24.81.24.8go get github.com/kubernetes/kubernetes@v1.24.8
🐹Gogithub.com/kubernetes/kubernetes≥ 1.23.0&&< 1.23.141.23.14go get github.com/kubernetes/kubernetes@v1.23.14
🐹Gogithub.com/kubernetes/kubernetes≥ 1.22.0&&< 1.22.161.22.16go get github.com/kubernetes/kubernetes@v1.22.16

Affected Products

1 product · 4 configurations
Application
kuberneteskubernetes
≥ 1.25.0 && < 1.25.4
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/kubernetes/kubernetes, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/kubernetes/kubernetes to 1.25.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-3294 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

Kubernetes clusters are only affected if an untrusted user can modify Node objects and send requests proxying through them. The "openshift" component of Red Hat OpenShift Container Platform 4 was fixed in RHBA-2023:0452 and as such is marked not affected.

ProductFixed inAdvisory
Red Hat OpenShift Container Platform 4.12microshift-0:4.12.1-202301261525.p0.g3db9e81.assembly.4.12.1.el8RHBA-2023:0452

Frequently Asked Questions

Users may have access to secure endpoints in the control plane network. Kubernetes clusters are only affected if an untrusted user can modify Node objects and send proxy requests to them. Kubernetes supports node proxying, which allows clients of kube-apiserver to access endpoints of a Kubelet to establish connections to Pods, retrieve container logs, and more. While Kubernetes already validates the proxying address for Nodes, a bug in kube-apiserver made it possible to bypass this validation. Bypassing this validation could allow authenticated requests destined for Nodes to to the API server'
O3 Security · Impact-Aware SCA

Is CVE-2022-3294 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2022-3294: kubernetes — Fixed in 1.25.4