NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
CRITICAL severity

CVE-2018-1002105 — kubernetes

CRITICALFix: kubernetes/kubernetes@2257c1e

CVE-2018-1002105 is a critical-severity (CVSS 9.8) CWE-388 vulnerability in github.com/kubernetes/kubernetes. 13 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for github.com/kubernetes/kubernetes — see the affected versions and patch details below.

Privilege Escalation in Kubernetes

Also known asGHSA-579h-mv94-g4gpGO-2022-0792
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
13 known
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
87.0%probability of exploitation in next 30 days
Very High Risk0.00%
Lower risk than most CVEs100th percentile — riskier than 100% of all scored CVEsHighest risk
85.8%87.9%89.9%91.9%90.8%87.0%May 26Sep 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐹github.com/kubernetes/kubernetes🐹github.com/kubernetes/kubernetes🐹github.com/kubernetes/kubernetes

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

In all Kubernetes versions prior to v1.10.11, v1.11.5, and v1.12.3, incorrect handling of error responses to proxied upgrade requests in the kube-apiserver allowed specially crafted requests to establish a connection through the Kubernetes API server to backend servers, then send arbitrary requests over the same connection directly to the backend, authenticated with the Kubernetes API server's TLS credentials used to establish the backend connection.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/kubernetes/kubernetesall versions1.10.11go get github.com/kubernetes/kubernetes@v1.10.11
🐹Gogithub.com/kubernetes/kubernetes≥ 1.11.0&&< 1.11.51.11.5go get github.com/kubernetes/kubernetes@v1.11.5
🐹Gogithub.com/kubernetes/kubernetes≥ 1.12.0&&< 1.12.31.12.3go get github.com/kubernetes/kubernetes@v1.12.3

Affected Products

3 products · 14 configurations
Application
kuberneteskubernetes
≥ 1.12.0 && ≤ 1.12.2
1 version
1.9.12
Application
tridentnetapp
all
Application
openshift container platformredhat
8 versions
3.23.33.43.53.63.83.103.11
Exploits & PoCs
13

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-46052remotemultiple

Kubernetes - (Unauthenticated) Arbitrary Requests

by evict · Dec 10, 2018

EDB-46053remotemultiple

Kubernetes - (Authenticated) Arbitrary Requests

by evict · Dec 10, 2018

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/kubernetes/kubernetes, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/kubernetes/kubernetes to 1.10.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-1002105 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatCritical

In versions 3.6 and higher of OpenShift Container Platform, this vulnerability allows cluster-admin level access to any API hosted by an aggregated API server. This includes the ‘service catalog’ API which is installed by default in 3.7 and later. Cluster-admin level access to the service catalog allows creation of…

Workaround published by Red Hat
See the vulnerability article for mitigation procedures.
Source: Red Hat security advisory for CVE-2018-1002105 (CC BY 4.0)
ProductFixed inAdvisory
Red Hat OpenShift Container Platform 3.10atomic-enterprise-service-catalog-1:3.10.72-1.git.1450.7d3f435.el7RHSA-2018:3549
Red Hat OpenShift Container Platform 3.11atomic-openshift-0:3.11.43-1.git.0.647ac05.el7RHSA-2018:3537
Red Hat OpenShift Container Platform 3.2atomic-openshift-0:3.2.1.34-2.git.20.6367d5d.el7RHSA-2018:3742
Red Hat OpenShift Container Platform 3.3atomic-openshift-0:3.3.1.46.45-1.git.0.2ce596e.el7RHSA-2018:3754
Red Hat OpenShift Container Platform 3.4atomic-openshift-0:3.4.1.44.57-1.git.0.a631031.el7RHSA-2018:3752
Red Hat OpenShift Container Platform 3.5atomic-openshift-0:3.5.5.31.80-1.git.0.c4a0780.el7RHSA-2018:3624
Red Hat OpenShift Container Platform 3.6atomic-openshift-0:3.6.173.0.140-1.git.0.9686d52.el7RHSA-2018:3598
Red Hat OpenShift Container Platform 3.7atomic-openshift-0:3.7.72-1.git.0.925b9cd.el7RHSA-2018:2906

Frequently Asked Questions

In all Kubernetes versions prior to v1.10.11, v1.11.5, and v1.12.3, incorrect handling of error responses to proxied upgrade requests in the kube-apiserver allowed specially crafted requests to establish a connection through the Kubernetes API server to backend servers, then send arbitrary requests over the same connection directly to the backend, authenticated with the Kubernetes API server's TLS credentials used to establish the backend connection.
O3 Security · Impact-Aware SCA

Is CVE-2018-1002105 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2018-1002105: kubernetes — Fixed in 1.10.11