NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
MEDIUM severity

CVE-2015-7528 — kubernetes

MEDIUMFix: kubernetes/kubernetes#17886

CVE-2015-7528 is a medium-severity (CVSS 5.3) Information Exposure vulnerability in github.com/kubernetes/kubernetes. A fix is available for github.com/kubernetes/kubernetes — see the affected versions and patch details below.

Information Exposure in Kubernetes

Also known asGO-2022-0857
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs82th percentile — riskier than 82% of all scored CVEsHighest risk
0.00%0.86%1.73%2.59%0.4%2.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐹github.com/kubernetes/kubernetes

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Kubernetes before 1.2.0-alpha.5 allows remote attackers to read arbitrary pod logs via a container name.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/kubernetes/kubernetesall versions1.2.0go get github.com/kubernetes/kubernetes@v1.2.0

Affected Products

2 products · 3 configurations
Application
kuberneteskubernetes
≤ 1.2.0
range
Application
openshiftredhat
2 versions
3.03.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/kubernetes/kubernetes, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/kubernetes/kubernetes to 1.2.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-7528 is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat OpenShift Enterprise 3.0openshift-0:3.0.2.0-0.git.38.7576bc5.el7oseRHSA-2015:2544
Red Hat OpenShift Enterprise 3.0see advisoryRHSA-2015:2615

Frequently Asked Questions

Kubernetes before 1.2.0-alpha.5 allows remote attackers to read arbitrary pod logs via a container name.
O3 Security · Impact-Aware SCA

Is CVE-2015-7528 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2015-7528: kubernetes — Fixed in 1.2.0