CVE-2022-31036 is a medium-severity (CVSS 4.3) Improper Input Validation vulnerability in github.com/argoproj/argo-cd. A fix is available for github.com/argoproj/argo-cd — see the affected versions and patch details below.
Symlink following allows leaking out-of-bounds YAML files from Argo CD repo-server
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-31036.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/argoproj/argo-cd🐹github.com/argoproj/argo-cd/v2🐹github.com/argoproj/argo-cd/v2🐹github.com/argoproj/argo-cd/v2🐹github.com/argoproj/argo-cd/v2Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Impact
All unpatched versions of Argo CD starting with v1.3.0 are vulnerable to a symlink following bug allowing a malicious user with repository write access to leak sensitive YAML files from Argo CD's repo-server.
A malicious Argo CD user with write access for a repository which is (or may be) used in a Helm-type Application may commit a symlink which points to an out-of-bounds file. If the target file is a valid YAML file, the attacker can read the contents of that file.
Sensitive files which could be leaked include manifest files from other Applications' source repositories (potentially decrypted files, if you are using a decryption plugin) or any YAML-formatted secrets which have been mounted as files on the repo-server.
Patches
A patch for this vulnerability has been released in the following Argo CD versions:
- v2.4.1
- v2.3.5
- v2.2.10
- v2.1.16
Workarounds
- If you are using >=v2.3.0 and do not have any Helm-type Applications, disable the Helm config management tool.
Mitigations
- Avoid mounting YAML-formatted secrets as files on the repo-server.
- Upgrade to >=2.3.0 to significantly reduce the risk of leaking out-of-bounds manifest files. Starting with 2.3.0, repository paths are randomized, and read permissions are restricted when manifests are not being actively being generated. This makes it very difficult to craft and use a malicious symlink.
Best practices which can mitigate risk
- Limit who has push access to manifest repositories.
- Limit who is allowed to configure new source repositories.
Credits
Disclosed by ADA Logics in a security audit of the Argo project sponsored by CNCF and facilitated by OSTIF. Thanks to Adam Korczynski and David Korczynski for their work on the audit.
References
- List of types of Applications, including Helm-type
- RBAC documentation, showing how to limit repository permissions
For more information
- Open an issue in the Argo CD issue tracker or discussions
- Join us on Slack in channel #argo-cd
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/argoproj/argo-cd | ≥ 1.3.0&&< 2.1.16 | 2.1.16go get github.com/argoproj/argo-cd@v2.1.16 |
| 🐹Go | github.com/argoproj/argo-cd/v2 | all versions | 2.1.16go get github.com/argoproj/argo-cd/v2@v2.1.16 |
| 🐹Go | github.com/argoproj/argo-cd/v2 | ≥ 2.2.0&&< 2.2.10 | 2.2.10go get github.com/argoproj/argo-cd/v2@v2.2.10 |
| 🐹Go | github.com/argoproj/argo-cd/v2 | ≥ 2.3.0&&< 2.3.5 | 2.3.5go get github.com/argoproj/argo-cd/v2@v2.3.5 |
| 🐹Go | github.com/argoproj/argo-cd/v2 | ≥ 2.4.0&&< 2.4.1 | 2.4.1go get github.com/argoproj/argo-cd/v2@v2.4.1 |
Affected Products
argo cdargoprojDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/argoproj/argo-cd, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/argoproj/argo-cd to 2.1.16 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-31036 is resolved across your whole dependency graph.
Workarounds
Stop feeding it untrusted input: reject or quarantine files and payloads from unverified sources until you can upgrade, restrict accepted formats to the ones you actually need, and run the parsing or decoding step in a least-privileged sandbox or short-lived worker so a crash or corrupted read cannot reach the rest of the process.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat OpenShift GitOps 1.3 | openshift-gitops-1/argocd-rhel8:v1.3.12-1 | RHSA-2022:5187 |
| Red Hat OpenShift GitOps 1.3 | openshift-gitops-1/argocd-rhel8:v1.3.11-4 | RHSA-2022:5192 |
| Red Hat OpenShift GitOps 1.4 | openshift-gitops-1/argocd-rhel8:v1.4.9-3 | RHSA-2022:5153 |
| Red Hat OpenShift GitOps 1.5 | openshift-gitops-1/argocd-rhel8:v1.5.3-2 | RHSA-2022:5152 |
Frequently Asked Questions
Is CVE-2022-31036 in your dependencies?
Find it across Go, including transitive dependencies.