CVE-2022-29254 is a low-severity (CVSS 3.7) CWE-436 vulnerability in silverstripe/silverstripe-omnipay. A fix is available for silverstripe/silverstripe-omnipay — see the affected versions and patch details below.
Failed payment recorded has completed in silverstripe/silverstripe-omnipay
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-29254.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
silverstripe/silverstripe-omnipay🐘silverstripe/silverstripe-omnipay🐘silverstripe/silverstripe-omnipay🐘silverstripe/silverstripe-omnipayReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Impact
For a subset of Omnipay gateways (those that use intermediary states like isNotification() or isRedirect()), if the payment identifier or success URL is exposed it is possible for payments to be prematurely marked as completed without payment being taken. This is mitigated by the fact that most payment gateways hide this information from users, however some issuing banks offer flawed 3DSecure implementations that may inadvertently expose this data.
Patches
The following versions have been patched to fix this issue:
2.5.23.0.23.1.43.2.1
Workarounds
There are no known workarounds for this vulnerability.
References
N/A.
For more information
If you have any questions or comments about this advisory:
- Email us at [email protected]
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | silverstripe/silverstripe-omnipay | all versions | 2.5.2composer require silverstripe/silverstripe-omnipay:^2.5.2 |
| 🐘Packagist | silverstripe/silverstripe-omnipay | ≥ 3.0.0&&< 3.0.2 | 3.0.2composer require silverstripe/silverstripe-omnipay:^3.0.2 |
| 🐘Packagist | silverstripe/silverstripe-omnipay | ≥ 3.1.0&&< 3.1.4 | 3.1.4composer require silverstripe/silverstripe-omnipay:^3.1.4 |
| 🐘Packagist | silverstripe/silverstripe-omnipay | ≥ 3.2.0&&< 3.2.1 | 3.2.1composer require silverstripe/silverstripe-omnipay:^3.2.1 |
Affected Products
silverstripe-omnipaysilverstripeDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for silverstripe/silverstripe-omnipay, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update silverstripe/silverstripe-omnipay to 2.5.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-29254 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2022-29254 in your dependencies?
Find it across Packagist, including transitive dependencies.