CVE-2022-29036 — credentials
MEDIUMCVE-2022-29036 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in org.jenkins-ci.plugins:credentials. EPSS puts its 30-day exploitation probability at 71.9% (99th percentile). A fix is available for org.jenkins-ci.plugins:credentials — see the affected versions and patch details below.
Cross-site Scripting in Jenkins Credentials Plugin
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.jenkins-ci.plugins:credentials☕org.jenkins-ci.plugins:credentials☕org.jenkins-ci.plugins:credentials☕org.jenkins-ci.plugins:credentialsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Jenkins Credentials Plugin 1111.v35a_307992395 and earlier, except 1087.1089.v2f1b_9a_b_040e4, 1074.1076.v39c30cecb_0e2, and 2.6.1.1, does not escape the name and description of Credentials parameters on views displaying parameters, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.jenkins-ci.plugins:credentials | all versions | 2.6.1.1org.jenkins-ci.plugins:credentials:2.6.1.1 |
| ☕Maven | org.jenkins-ci.plugins:credentials | ≥ 2.6.2&&< 1074.1076.v39c30cecb_0e2 | 1074.1076.v39c30cecb_0e2org.jenkins-ci.plugins:credentials:1074.1076.v39c30cecb_0e2 |
| ☕Maven | org.jenkins-ci.plugins:credentials | ≥ 1087.v16065d268466&&< 1087.1089.v2f1b_9a_b_040e4 | 1087.1089.v2f1b_9a_b_040e4org.jenkins-ci.plugins:credentials:1087.1089.v2f1b_9a_b_040e4 |
| ☕Maven | org.jenkins-ci.plugins:credentials | ≥ 1105 | No fix |
Affected Products
credentialsjenkinsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jenkins-ci.plugins:credentials, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.jenkins-ci.plugins:credentials to 2.6.1.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-29036 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat OpenShift Container Platform 3.11 | jenkins-2-plugins-0:3.11.1650628887-1.el7 | RHSA-2022:2280 |
| Red Hat OpenShift Container Platform 4.10 | jenkins-2-plugins-0:4.10.1650890594-1.el8 | RHSA-2022:1600 |
| Red Hat OpenShift Container Platform 4.6 | jenkins-2-plugins-0:4.6.1653312933-1.el8 | RHSA-2022:4947 |
| Red Hat OpenShift Container Platform 4.7 | jenkins-2-plugins-0:4.7.1652967082-1.el8 | RHSA-2022:4909 |
| Red Hat OpenShift Container Platform 4.8 | jenkins-2-plugins-0:4.8.1646993358-1.el8 | RHSA-2022:0871 |
| Red Hat OpenShift Container Platform 4.9 | jenkins-2-plugins-0:4.9.1651754460-1.el8 | RHSA-2022:2205 |
Frequently Asked Questions
Is CVE-2022-29036 in your dependencies?
Find it across Maven, including transitive dependencies.