CVE-2021-21648 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.jenkins-ci.plugins:credentials. EPSS puts its 30-day exploitation probability at 11.3% (96th percentile). A fix is available for org.jenkins-ci.plugins:credentials — see the affected versions and patch details below.
Cross-Site Request Forgery in Jenkins Credentials Plugin
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.jenkins-ci.plugins:credentials☕org.jenkins-ci.plugins:credentials☕org.jenkins-ci.plugins:credentials☕org.jenkins-ci.plugins:credentials☕org.jenkins-ci.plugins:credentials☕org.jenkins-ci.plugins:credentialsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Jenkins Credentials Plugin prior to 2.3.19, 2.3.15.1, 2.3.14.1, 2.3.13.1, 2.3.7.1, and 2.3.0.1 does not escape user-controlled information on a view it provides, resulting in a reflected cross-site scripting (XSS) vulnerability.
Jenkins Credentials Plugin 2.3.19, 2.3.15.1, 2.3.14.1, 2.3.13.1, 2.3.7.1, and 2.3.0.1 restricts the user-controlled information it provides to a safe subset.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.jenkins-ci.plugins:credentials | ≥ 2.3.16&&< 2.3.19 | 2.3.19org.jenkins-ci.plugins:credentials:2.3.19 |
| ☕Maven | org.jenkins-ci.plugins:credentials | ≥ 2.3.15&&< 2.3.15.1 | 2.3.15.1org.jenkins-ci.plugins:credentials:2.3.15.1 |
| ☕Maven | org.jenkins-ci.plugins:credentials | ≥ 2.3.14&&< 2.3.14.1 | 2.3.14.1org.jenkins-ci.plugins:credentials:2.3.14.1 |
| ☕Maven | org.jenkins-ci.plugins:credentials | ≥ 2.3.8&&< 2.3.13.1 | 2.3.13.1org.jenkins-ci.plugins:credentials:2.3.13.1 |
| ☕Maven | org.jenkins-ci.plugins:credentials | ≥ 2.3.1&&< 2.3.7.1 | 2.3.7.1org.jenkins-ci.plugins:credentials:2.3.7.1 |
| ☕Maven | org.jenkins-ci.plugins:credentials | all versions | 2.3.0.1org.jenkins-ci.plugins:credentials:2.3.0.1 |
Affected Products
credentialsjenkinsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jenkins-ci.plugins:credentials, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.jenkins-ci.plugins:credentials to 2.3.19 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-21648 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat OpenShift Container Platform 4.8 | jenkins-2-plugins-0:4.8.1624022417-1.el8 | RHSA-2021:2437 |
Frequently Asked Questions
Is CVE-2021-21648 in your dependencies?
Find it across Maven, including transitive dependencies.