NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2018-1000601 — ssh-credentials

MEDIUMFix: jenkinsci/credentials-plugin@23fbd6d

CVE-2018-1000601 is a medium-severity (CVSS 6.5) Information Exposure vulnerability in org.jenkins-ci.plugins:ssh-credentials. A fix is available for org.jenkins-ci.plugins:ssh-credentials — see the affected versions and patch details below.

Exposure of Sensitive Information to an Unauthorized Actor in Jenkins SSH Credentials Plugin

Also known asGHSA-cwcf-5m5w-mq2w
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs63th percentile — riskier than 63% of all scored CVEsHighest risk
0.00%0.50%1.01%1.51%0.3%1.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.jenkins-ci.plugins:ssh-credentials☕org.jenkins-ci.plugins:credentials

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

A arbitrary file read vulnerability exists in Jenkins SSH Credentials Plugin 1.13 and earlier in BasicSSHUserPrivateKey.java that allows attackers with a Jenkins account and the permission to configure credential bindings to read arbitrary files from the Jenkins master file system.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jenkins-ci.plugins:ssh-credentialsall versions1.14org.jenkins-ci.plugins:ssh-credentials:1.14
☕Mavenorg.jenkins-ci.plugins:credentialsall versions2.1.17org.jenkins-ci.plugins:credentials:2.1.17

Affected Products

1 product · 1 configurations
Application
ssh credentialsjenkins
≤ 1.13
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jenkins-ci.plugins:ssh-credentials, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jenkins-ci.plugins:ssh-credentials to 1.14 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-1000601 is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Frequently Asked Questions

A arbitrary file read vulnerability exists in Jenkins SSH Credentials Plugin 1.13 and earlier in BasicSSHUserPrivateKey.java that allows attackers with a Jenkins account and the permission to configure credential bindings to read arbitrary files from the Jenkins master file system.
O3 Security · Impact-Aware SCA

Is CVE-2018-1000601 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2018-1000601: ssh-credentials — Fixed in 1.14