CVE-2022-27115 is a critical-severity (CVSS 9.8) Unrestricted File Upload vulnerability in studio-42/elfinder. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for studio-42/elfinder — see the affected versions and patch details below.
RCE in Studio-42 elFinder on Windows before 2.1.61
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
studio-42/elfinderReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
In Studio-42 elFinder 2.1.60, there is a vulnerability that causes remote code execution through file name bypass for file upload.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | studio-42/elfinder | all versions | 2.1.61composer require studio-42/elfinder:^2.1.61 |
Affected Products
elfinderstd42Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for studio-42/elfinder, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update studio-42/elfinder to 2.1.61 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-27115 is resolved across your whole dependency graph.
Workarounds
Treat uploaded files as untrusted until proven otherwise: validate the actual content type rather than the supplied extension, store uploads outside the web root on a volume mounted without execute permission, and rename them to server-generated identifiers so an attacker cannot choose the path a request will later resolve.
Frequently Asked Questions
Is CVE-2022-27115 in your dependencies?
Find it across Packagist, including transitive dependencies.