NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2022-26596 — com.liferay.journal.conte…

MEDIUMFix: liferay/liferay-portal@c61976f

CVE-2022-26596 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in com.liferay:com.liferay.journal.content.web. A fix is available for com.liferay:com.liferay.journal.content.web — see the affected versions and patch details below.

Liferay Portal and Liferay DXP allows arbitrary injection via web content template names

Also known asBIT-liferay-2022-26596GHSA-w7f2-6896-6mm2
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Oct 26, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs54th percentile — riskier than 54% of all scored CVEsHighest risk
0.00%0.41%0.81%1.22%0.2%0.7%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
☕com.liferay:com.liferay.journal.content.web☕com.liferay.portal:release.dxp.bom☕com.liferay.portal:release.dxp.bom☕com.liferay.portal:release.dxp.bom

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting (XSS) vulnerability in Journal module's web content display configuration page before 5.0.15 in Liferay Portal 7.1.0 through 7.3.3, and Liferay DXP 7.0 before fix pack 94, 7.1 before fix pack 19, and 7.2 before fix pack 8, allows remote attackers to inject arbitrary web script or HTML via web content template names.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
☕Mavencom.liferay:com.liferay.journal.content.weball versions5.0.15com.liferay:com.liferay.journal.content.web:5.0.15
☕Mavencom.liferay.portal:release.dxp.bom≥ 7.0.0&&< 7.0.10.fp947.0.10.fp94com.liferay.portal:release.dxp.bom:7.0.10.fp94
☕Mavencom.liferay.portal:release.dxp.bom≥ 7.1.0&&< 7.1.10.fp197.1.10.fp19com.liferay.portal:release.dxp.bom:7.1.10.fp19
☕Mavencom.liferay.portal:release.dxp.bom≥ 7.2.0&&< 7.2.10.fp87.2.10.fp8com.liferay.portal:release.dxp.bom:7.2.10.fp8

Affected Products

2 products · 114 configurations
Application
digital experience platformliferay
3 versions
7.07.17.2
Application
liferay portalliferay
≥ 7.1.0 && ≤ 7.3.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.liferay:com.liferay.journal.content.web, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update com.liferay:com.liferay.journal.content.web to 5.0.15 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-26596 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in Journal module's web content display configuration page before 5.0.15 in Liferay Portal 7.1.0 through 7.3.3, and Liferay DXP 7.0 before fix pack 94, 7.1 before fix pack 19, and 7.2 before fix pack 8, allows remote attackers to inject arbitrary web script or HTML via web content template names.
O3 Security · Impact-Aware SCA

Is CVE-2022-26596 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2022-26596: com.liferay.journal XSS — Fixed in 5.0.15