CVE-2022-24878 — kustomize-controller
HIGHCVE-2022-24878 is a high-severity (CVSS 7.7) Path Traversal vulnerability in github.com/fluxcd/kustomize-controller. A fix is available for github.com/fluxcd/kustomize-controller — see the affected versions and patch details below.
Improper path handling in Kustomization files allows for denial of service
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-24878.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/fluxcd/kustomize-controller🐹github.com/fluxcd/flux2Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
The kustomize-controller enables the use of Kustomize’s functionality when applying Kubernetes declarative state onto a cluster. A malicious user can use a specially crafted kustomization.yaml to cause Denial of Service at controller level.
In multi-tenancy deployments this can lead to multiple tenants not being able to apply their Kustomizations until the malicious kustomization.yaml is removed and the controller restarted.
Impact
Within the affected versions, users with write access to a Flux source are able to craft a malicious kustomization.yaml file which causes the controller to enter an endless loop.
Patches
This vulnerability was fixed in kustomize-controller v0.24.0 and included in flux2 v0.29.0 released on 2022-04-20. The changes introduce better handling of Kustomization files blocking references that could lead to endless loops.
Credits
The Flux engineering team found and patched this vulnerability.
For more information
If you have any questions or comments about this advisory please open an issue in the flux2 repository.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/fluxcd/kustomize-controller | ≥ 0.16.0&&< 0.24.0 | 0.24.0go get github.com/fluxcd/kustomize-controller@v0.24.0 |
| 🐹Go | github.com/fluxcd/flux2 | ≥ 0.19.0&&< 0.29.0 | 0.29.0go get github.com/fluxcd/flux2@v0.29.0 |
Affected Products
flux2fluxcdkustomize-controllerfluxcdDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/fluxcd/kustomize-controller, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/fluxcd/kustomize-controller to 0.24.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-24878 is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
Frequently Asked Questions
Is CVE-2022-24878 in your dependencies?
Find it across Go, including transitive dependencies.