CVE-2022-24817 — flux2
CRITICALCVE-2022-24817 is a critical-severity (CVSS 9.9) Code Injection vulnerability in github.com/fluxcd/flux2. A fix is available for github.com/fluxcd/flux2 — see the affected versions and patch details below.
Improper kubeconfig validation allows arbitrary code execution
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-24817.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/fluxcd/flux2🐹github.com/fluxcd/kustomize-controller🐹github.com/fluxcd/helm-controllerReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Flux2 can reconcile the state of a remote cluster when provided with a kubeconfig with the correct access rights. Kubeconfig files can define commands to be executed to generate on-demand authentication tokens. A malicious user with write access to a Flux source or direct access to the target cluster, could craft a kubeconfig to execute arbitrary code inside the controller’s container.
In multi-tenancy deployments this can also lead to privilege escalation if the controller's service account has elevated permissions.
Impact
Within the affected versions range, one of the permissions set below would be required for the vulnerability to be exploited:
- Direct access to the cluster to create Flux
KustomizationorHelmReleaseobjects and Kubernetes Secrets. - Direct access to the cluster to modify existing Kubernetes secrets being used as
kubeconfigin existing FluxKustomizationorHelmReleaseobjects. - Direct access to the cluster to modify existing Flux
KustomizationorHelmReleaseobjects and access to create or modify existing Kubernetes secrets. - Access rights to make changes to a configured Flux Source (i.e. Git repository).
Patches
This vulnerability was fixed in kustomize-controller v0.23.0 and helm-controller v0.19.0, both included in flux2 v0.29.0. Starting from the fixed versions, both controllers disable the use of command execution from kubeconfig files by default, users have to opt-in by adding the flag --insecure-kubeconfig-exec to the controller’s command arguments. Users are no longer allowed to refer to files in the controller’s filesystem in the kubeconfig files provided for the remote apply feature.
Workarounds
- The functionality can be disabled via Validating Admission webhooks (e.g. OPA Gatekeeper, Kyverno) by restricting users from being able to set the
spec.kubeConfigfield in FluxKustomizationandHelmReleaseobjects. - Applying restrictive AppArmor and SELinux profiles on the controller’s pod to limit what binaries can be executed.
Credits
The Flux engineering team found and patched this vulnerability.
For more information
If you have any questions or comments about this advisory please open an issue in the flux2 repository.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/fluxcd/flux2 | ≥ 0.1.0&&< 0.29.0 | 0.29.0go get github.com/fluxcd/flux2@v0.29.0 |
| 🐹Go | github.com/fluxcd/kustomize-controller | ≥ 0.1.0&&< 0.23.0 | 0.23.0go get github.com/fluxcd/kustomize-controller@v0.23.0 |
| 🐹Go | github.com/fluxcd/helm-controller | ≥ 0.2.0&&< 0.19.0 | 0.19.0go get github.com/fluxcd/helm-controller@v0.19.0 |
Affected Products
flux2fluxcdhelm-controllerfluxcdkustomize-controllerfluxcdDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/fluxcd/flux2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/fluxcd/flux2 to 0.29.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-24817 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is CVE-2022-24817 in your dependencies?
Find it across Go, including transitive dependencies.