CVE-2022-24730 — argo-cd
HIGHCVE-2022-24730 is a high-severity (CVSS 7.7) Path Traversal vulnerability in github.com/argoproj/argo-cd. A fix is available for github.com/argoproj/argo-cd — see the affected versions and patch details below.
Path traversal and improper access control allows leaking out-of-bound files from Argo CD repo-server
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-24730.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/argoproj/argo-cd🐹github.com/argoproj/argo-cd🐹github.com/argoproj/argo-cdReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Impact
All unpatched versions of Argo CD starting with v1.3.0 are vulnerable to a path traversal bug, compounded by an improper access control bug, allowing a malicious user with read-only repository access to leak sensitive files from Argo CD's repo-server.
A malicious Argo CD user who has been granted get access for a repository containing a Helm chart can craft an API request to the /api/v1/repositories/{repo_url}/appdetails endpoint to leak the contents of out-of-bounds files from the repo-server.
The malicious payload would reference an out-of-bounds file, and the contents of that file would be returned as part of the response. Contents from a non-YAML file may be returned as part of an error message. The attacker would have to know or guess the location of the target file.
Sensitive files which could be leaked include files from other Applications' source repositories (potentially decrypted files, if you are using a decryption plugin) or any secrets which have been mounted as files on the repo-server.
Patches
A patch for this vulnerability has been released in the following Argo CD versions:
- v2.3.0
- v2.2.6
- v2.1.11
The patches do two things:
- prevent path traversal
- limit
/api/v1/repositories/{repo_url}/appdetailsaccess to users who either A) have been granted Applicationcreateprivileges or B) have been granted Applicationgetprivileges and are requesting details for arepo_urlthat has already been used for the given Application
Workarounds
The only certain way to avoid the vulnerability is to upgrade.
To mitigate the problem, you can
- avoid storing secrets in git
- avoid mounting secrets as files on the repo-server
- avoid decrypting secrets into files on the repo-server
- carefully limit who has
getaccess for repositories
References
For more information
Open an issue in the Argo CD issue tracker or discussions Join us on Slack in channel #argo-cd
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/argoproj/argo-cd | ≥ 1.3.0&&< 2.1.11 | 2.1.11go get github.com/argoproj/argo-cd@v2.1.11 |
| 🐹Go | github.com/argoproj/argo-cd | ≥ 2.2.0&&< 2.2.6 | 2.2.6go get github.com/argoproj/argo-cd@v2.2.6 |
| 🐹Go | github.com/argoproj/argo-cd | ≥ 2.3.0-rc1&&< 2.3.0 | 2.3.0go get github.com/argoproj/argo-cd@v2.3.0 |
Affected Products
argo cdargoprojDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/argoproj/argo-cd, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/argoproj/argo-cd to 2.1.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-24730 is resolved across your whole dependency graph.
Workarounds
Stop feeding it untrusted input: reject or quarantine files and payloads from unverified sources until you can upgrade, restrict accepted formats to the ones you actually need, and run the parsing or decoding step in a least-privileged sandbox or short-lived worker so a crash or corrupted read cannot reach the rest of the process.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat OpenShift GitOps 1.2 | openshift-gitops-1/argocd-rhel8:v1.2.3-3 | RHSA-2022:1039 |
| Red Hat OpenShift GitOps 1.3 | openshift-gitops-1/argocd-rhel8:v1.3.5-4 | RHSA-2022:1040 |
| Red Hat OpenShift GitOps 1.3 | openshift-gitops-1/argocd-rhel8:v1.3.6-3 | RHSA-2022:1042 |
| Red Hat OpenShift GitOps 1.4 | openshift-gitops-1/argocd-rhel8:v1.4.4-6 | RHSA-2022:1041 |
Frequently Asked Questions
Is CVE-2022-24730 in your dependencies?
Find it across Go, including transitive dependencies.