NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
MEDIUM severity

CVE-2022-2401 — mattermost-server

MEDIUM

CVE-2022-2401 is a medium-severity (CVSS 6.5) Information Exposure vulnerability in github.com/mattermost/mattermost-server/v6. A fix is available for github.com/mattermost/mattermost-server/v6 — see the affected versions and patch details below.

Team members could access sensitive information of other users via an API call

Also known asBIT-mattermost-2022-2401GHSA-7ggc-5r84-xf54GO-2022-0540
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-2401.

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs58th percentile — riskier than 58% of all scored CVEsHighest risk
0.00%0.44%0.89%1.33%0.3%0.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐹github.com/mattermost/mattermost-server/v6🐹github.com/mattermost/mattermost-server/v6🐹github.com/mattermost/mattermost-server/v6🐹github.com/mattermost/mattermost-server/v6

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Unrestricted information disclosure of all users in Mattermost version 6.7.0 and earlier allows team members to access some sensitive information by directly accessing the APIs.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/mattermost/mattermost-server/v6all versions6.3.9go get github.com/mattermost/mattermost-server/v6@v6.3.9
🐹Gogithub.com/mattermost/mattermost-server/v6≥ 6.4.0&&< 6.5.26.5.2go get github.com/mattermost/mattermost-server/v6@v6.5.2
🐹Gogithub.com/mattermost/mattermost-server/v6≥ 6.6.0&&< 6.6.26.6.2go get github.com/mattermost/mattermost-server/v6@v6.6.2
🐹Gogithub.com/mattermost/mattermost-server/v6≥ 6.7.0&&< 6.7.16.7.1go get github.com/mattermost/mattermost-server/v6@v6.7.1

Affected Products

1 product · 5 configurations
Application
mattermost servermattermost
≥ 6.4.0 && < 6.5.2
3 versions
6.6.06.6.16.7.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/mattermost/mattermost-server/v6, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/mattermost/mattermost-server/v6 to 6.3.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-2401 is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Frequently Asked Questions

Unrestricted information disclosure of all users in Mattermost version 6.7.0 and earlier allows team members to access some sensitive information by directly accessing the APIs.
O3 Security · Impact-Aware SCA

Is CVE-2022-2401 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2022-2401: mattermost — Fixed in 6.3.9