NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
MEDIUM severity

CVE-2022-1332 — mattermost-server

MEDIUM

CVE-2022-1332 is a medium-severity (CVSS 4.3) Information Exposure vulnerability in github.com/mattermost/mattermost-server/v6. A fix is available for github.com/mattermost/mattermost-server/v6 — see the affected versions and patch details below.

Restricted custom admin role can bypass the restrictions and view the server logs and server config.json file contents

Also known asBIT-mattermost-2022-1332GHSA-qggc-pj29-j27mGO-2022-0616
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Oct 29, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-1332.

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs51th percentile — riskier than 51% of all scored CVEsHighest risk
0.00%0.38%0.77%1.15%0.1%0.7%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐹github.com/mattermost/mattermost-server/v6🐹github.com/mattermost/mattermost-server/v6🐹github.com/mattermost/mattermost-server/v6🐹github.com/mattermost/mattermost-server/v5

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

One of the API in Mattermost version 6.4.1 and earlier fails to properly protect the permissions, which allows the authenticated members with restricted custom admin role to bypass the restrictions and view the server logs and server config.json file contents. Per the Mattermost security updates page, versions 6.4.2, 6.3.5, 6.2.5, and 5.37.9 contain patches for this issue

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/mattermost/mattermost-server/v6≥ 6.4.0&&< 6.4.26.4.2go get github.com/mattermost/mattermost-server/v6@v6.4.2
🐹Gogithub.com/mattermost/mattermost-server/v6≥ 6.3.0&&< 6.3.56.3.5go get github.com/mattermost/mattermost-server/v6@v6.3.5
🐹Gogithub.com/mattermost/mattermost-server/v6≥ 6.0.0&&< 6.2.56.2.5go get github.com/mattermost/mattermost-server/v6@v6.2.5
🐹Gogithub.com/mattermost/mattermost-server/v5all versions5.37.9go get github.com/mattermost/mattermost-server/v5@v5.37.9

Affected Products

1 product · 4 configurations
Application
mattermost servermattermost
≥ 6.4.0 && < 6.4.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/mattermost/mattermost-server/v6, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/mattermost/mattermost-server/v6 to 6.4.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-1332 is resolved across your whole dependency graph.

  3. Workarounds

    Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.

Frequently Asked Questions

One of the API in Mattermost version 6.4.1 and earlier fails to properly protect the permissions, which allows the authenticated members with restricted custom admin role to bypass the restrictions and view the server logs and server config.json file contents. Per the Mattermost security updates page, versions 6.4.2, 6.3.5, 6.2.5, and 5.37.9 contain patches for this issue
O3 Security · Impact-Aware SCA

Is CVE-2022-1332 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2022-1332: mattermost-server — Fixed in 6.4.2