NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2022-0602 — tastyigniter

HIGHFix: tastyigniter/tastyigniter@992d4ce

CVE-2022-0602 is a high-severity (CVSS 7.4) Cross-site Scripting (XSS) vulnerability in tastyigniter/tastyigniter. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for tastyigniter/tastyigniter — see the affected versions and patch details below.

Cross-site Scripting (XSS) - DOM in tastyigniter/tastyigniter

Also known asGHSA-cjw5-f2x5-r4q5
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs54th percentile — riskier than 54% of all scored CVEsHighest risk
0.00%0.41%0.81%1.22%0.2%0.7%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘tastyigniter/tastyigniter

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

TastyIgniter prior to version 3.3.0 is vulnerable to Document Object Model (DOM) based Cross-site Scripting (XSS).

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagisttastyigniter/tastyigniterall versions3.3.0composer require tastyigniter/tastyigniter:^3.3.0

Affected Products

1 product · 1 configurations
Application
tastyignitertastyigniter
< 3.3.0
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for tastyigniter/tastyigniter, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update tastyigniter/tastyigniter to 3.3.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-0602 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

TastyIgniter prior to version 3.3.0 is vulnerable to Document Object Model (DOM) based Cross-site Scripting (XSS).
O3 Security · Impact-Aware SCA

Is CVE-2022-0602 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2022-0602: tastyigniter XSS — Fixed in 3.3.0