CVE-2024-44314 — tastyigniter
MEDIUMCVE-2024-44314 is a medium-severity (CVSS 6.5) CWE-285 vulnerability in tastyigniter/tastyigniter. A fix is available for tastyigniter/tastyigniter — see the affected versions and patch details below.
TastyIgniter Has an Incorrect Access Control Vulnerability
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-44314.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
tastyigniter/tastyigniterReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
TastyIgniter 3.7.6 contains an Incorrect Access Control vulnerability in the Orders Management System, allowing unauthorized users to update order statuses. The issue occurs in the index_onUpdateStatus() function within Orders.php, which fails to verify if the user has permission to modify an order's status. This flaw can be exploited remotely, leading to unauthorized order manipulation.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | tastyigniter/tastyigniter | all versions | 4.0.0composer require tastyigniter/tastyigniter:^4.0.0 |
Affected Products
tastyignitertastyigniterDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for tastyigniter/tastyigniter, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update tastyigniter/tastyigniter to 4.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-44314 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2024-44314 in your dependencies?
Find it across Packagist, including transitive dependencies.