NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

CVE-2022-0436 — grunt

HIGHFix: gruntjs/grunt@aad3d45

CVE-2022-0436 is a high-severity (CVSS 7.1) Path Traversal vulnerability in grunt. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for grunt — see the affected versions and patch details below.

Path Traversal in gruntjs/grunt

Also known asGHSA-j383-35pm-c5h4
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 23, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk+0.01%
Lower risk than most CVEs47th percentile — riskier than 47% of all scored CVEsHighest risk
0.00%0.36%0.73%1.09%0.1%0.6%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

2Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
gruntnpm
796Kdownloads / week

Description

Path Traversal in GitHub repository gruntjs/grunt prior to 1.5.2.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmgruntall versions1.5.2npm install grunt@1.5.2

Affected Products

1 product · 1 configurations
Application
gruntgruntjs
< 1.5.2
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for grunt, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update grunt to 1.5.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-0436 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Frequently Asked Questions

Grunt prior to version 1.5.2 is vulnerable to path traversal.
O3 Security · Impact-Aware SCA

Is CVE-2022-0436 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2022-0436: grunt Path Traversal — Fixed in 1.5.2