NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

CVE-2020-7729 — grunt

HIGHFix: gruntjs/grunt@e350cea

CVE-2020-7729 is a high-severity (CVSS 7.1) CWE-1188 vulnerability in grunt. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for grunt — see the affected versions and patch details below.

Arbitrary Code Execution in grunt

Also known asGHSA-m5pj-vjjf-4m3h
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs83th percentile — riskier than 83% of all scored CVEsHighest risk
1.78%2.16%2.54%2.92%2.4%2.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

2Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
gruntnpm
1.4Mdownloads / week

Description

The package grunt before 1.3.0 are vulnerable to Arbitrary Code Execution due to the default usage of the function load() instead of its secure replacement safeLoad() of the package js-yaml inside grunt.file.readYAML.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmgruntall versions1.3.0npm install grunt@1.3.0

Affected Products

3 products · 3 configurations
OS
ubuntu linuxcanonical
1 version
18.04
OS
debian linuxdebian
1 version
9.0
Application
gruntgruntjs
< 1.3.0
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for grunt, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update grunt to 1.3.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-7729 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

The package grunt before 1.3.0 are vulnerable to Arbitrary Code Execution due to the default usage of the function load() instead of its secure replacement safeLoad() of the package js-yaml inside grunt.file.readYAML.
O3 Security · Impact-Aware SCA

Is CVE-2020-7729 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2020-7729: grunt RCE — Fixed in 1.3.0