CVE-2021-44521 — cassandra-all
CRITICALCVE-2021-44521 is a critical-severity (CVSS 9.1) Code Injection vulnerability in org.apache.cassandra:cassandra-all. 4 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.apache.cassandra:cassandra-all — see the affected versions and patch details below.
Apache Cassandra vulnerable to Code Injection due to unsafe configuration
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.cassandra:cassandra-all☕org.apache.cassandra:cassandra-all☕org.apache.cassandra:cassandra-allReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
When running Apache Cassandra with the following configuration: enable_user_defined_functions: true enable_scripted_user_defined_functions: true enable_user_defined_functions_threads: false it is possible for an attacker to execute arbitrary code on the host. The attacker would need to have enough permissions to create user defined functions in the cluster to be able to exploit this. Note that this configuration is documented as unsafe, and will continue to be considered unsafe after this CVE.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.cassandra:cassandra-all | all versions | 3.0.26org.apache.cassandra:cassandra-all:3.0.26 |
| ☕Maven | org.apache.cassandra:cassandra-all | ≥ 3.11.0&&< 3.11.12 | 3.11.12org.apache.cassandra:cassandra-all:3.11.12 |
| ☕Maven | org.apache.cassandra:cassandra-all | ≥ 4.0.0&&< 4.0.2 | 4.0.2org.apache.cassandra:cassandra-all:4.0.2 |
Affected Products
cassandraapacheResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.cassandra:cassandra-all, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.cassandra:cassandra-all to 3.0.26 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-44521 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is CVE-2021-44521 in your dependencies?
Find it across Maven, including transitive dependencies.