CVE-2021-41819 — cgi
HIGHCVE-2021-41819 is a high-severity (CVSS 7.5) CWE-565 vulnerability in cgi. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for cgi — see the affected versions and patch details below.
Cookie Prefix Spoofing in CGI::Cookie.parse
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2021-41819.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
cgi💎cgi💎cgiReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
CGI::Cookie.parse in Ruby through 2.6.8 mishandles security prefixes in cookie names. This also affects the CGI gem prior to versions 0.3.1, 0.2.1, 0.1.1, and 0.1.0.1 for Ruby.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | cgi | ≥ 0.3.0&&< 0.3.1 | 0.3.1bundle update cgi --conservative |
| 💎RubyGems | cgi | ≥ 0.2.0&&< 0.2.1 | 0.2.1bundle update cgi --conservative |
| 💎RubyGems | cgi | all versions | 0.1.0.1bundle update cgi --conservative |
Affected Products
debian linuxdebianfedorafedoraprojectfactoryopensuseleapopensuseenterprise linuxredhatsoftware collectionsredhatResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for cgi, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update cgi to 0.3.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-41819 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 8 | ruby:2.6-8050020211215144356.c5368500 | RHSA-2022:0543 |
| Red Hat Enterprise Linux 8 | ruby:2.5-8060020220715152618.ad008a3a | RHSA-2022:5779 |
| Red Hat Enterprise Linux 8 | ruby:2.7-8060020220728151401.ad008a3a | RHSA-2022:6447 |
| Red Hat Enterprise Linux 8 | ruby:3.0-8060020220810162001.ad008a3a | RHSA-2022:6450 |
| Red Hat Enterprise Linux 8.1 Update Services for SAP Solutions | ruby:2.6-8010020220201152941.c27ad7f8 | RHSA-2022:0581 |
| Red Hat Enterprise Linux 8.2 Extended Update Support | ruby:2.6-8020020220201131207.4cda2c84 | RHSA-2022:0582 |
| Red Hat Enterprise Linux 8.4 Extended Update Support | ruby:2.6-8040020220131135901.522a0ee4 | RHSA-2022:0544 |
| Red Hat Software Collections for Red Hat Enterprise Linux 7 | rh-ruby26-ruby-0:2.6.9-120.el7 | RHSA-2022:0708 |
Frequently Asked Questions
Is CVE-2021-41819 in your dependencies?
Find it across RubyGems, including transitive dependencies.