NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven📦 npm.NET NuGet💎 RubyGems
Not in CISA KEV
MEDIUM severity

CVE-2021-41182 — jquery-ui

MEDIUMFix: jquery/jquery-ui#1954

CVE-2021-41182 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.webjars.npm:jquery-ui. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.webjars.npm:jquery-ui — see the affected versions and patch details below.

XSS in the `altField` option of the Datepicker widget in jquery-ui

Also known asBIT-drupal-2021-41182GHSA-9gj3-hwp5-pmwc
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
1 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
39.4%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs99th percentile — riskier than 99% of all scored CVEsHighest risk
24.0%30.3%36.6%42.9%27.5%39.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

696other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
jquery-uinpm
970Kdownloads / week

Description

Impact

Accepting the value of the altField option of the Datepicker widget from untrusted sources may execute untrusted code. For example, initializing the datepicker in the following way:

$( "#datepicker" ).datepicker( {
	altField: "<img onerror='doEvilThing()' src='/404' />",
} );

will call the doEvilThing function.

Patches

The issue is fixed in jQuery UI 1.13.0. Any string value passed to the altField option is now treated as a CSS selector.

Workarounds

A workaround is to not accept the value of the altField option from untrusted sources.

For more information

If you have any questions or comments about this advisory, search for a relevant issue in the jQuery UI repo. If you don't find an answer, open a new issue.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.webjars.npm:jquery-uiall versions1.13.0org.webjars.npm:jquery-ui:1.13.0
📦npmjquery-uiall versions1.13.0npm install jquery-ui@1.13.0
.NETNuGetjQuery.UI.Combinedall versions1.13.0dotnet add package jQuery.UI.Combined --version 1.13.0
💎RubyGemsjquery-ui-railsall versions7.0.0bundle update jquery-ui-rails --conservative

Affected Products

29 products · 64 configurations
OS
debian linuxdebian
1 version
9.0
Application
drupaldrupal
≥ 7.0 && < 7.86
range
OS
fedorafedoraproject
4 versions
33343536
Application
jquery uijqueryui
< 1.13.0
range
OS
h300e firmwarenetapp
all
OS
h300s firmwarenetapp
all
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.webjars.npm:jquery-ui, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.webjars.npm:jquery-ui to 1.13.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-41182 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat Virtualization Engine 4.4org.ovirt.engine-root-0:4.5.0.7-9RHSA-2022:4711

Frequently Asked Questions

### Impact Accepting the value of the `altField` option of the Datepicker widget from untrusted sources may execute untrusted code. For example, initializing the datepicker in the following way: ```js $( "#datepicker" ).datepicker( { altField: "<img onerror='doEvilThing()' src='/404' />", } ); ``` will call the `doEvilThing` function. ### Patches The issue is fixed in jQuery UI 1.13.0. Any string value passed to the `altField` option is now treated as a CSS selector. ### Workarounds A workaround is to not accept the value of the `altField` option from untrusted sources. ### For more inform
O3 Security · Impact-Aware SCA

Is CVE-2021-41182 in your dependencies?

Find it across Maven, npm, NuGet, including transitive dependencies.

CVE-2021-41182: jquery-ui — Fixed in 1.13.0