NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven📦 npm.NET NuGet💎 RubyGems
Not in CISA KEV
MEDIUM severity

CVE-2016-7103 — jquery-ui

MEDIUMFix: jquery/jquery-ui@9644e7b

CVE-2016-7103 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.webjars.npm:jquery-ui. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.webjars.npm:jquery-ui — see the affected versions and patch details below.

jQuery-UI vulnerable to Cross-site Scripting in dialog closeText

Also known asGHSA-hpcf-8vf9-q4gj
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
1 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
29.2%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs98th percentile — riskier than 98% of all scored CVEsHighest risk
0.00%12.5%25.0%37.5%1.4%29.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

696other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
jquery-uinpm
968Kdownloads / week

Description

Affected versions of jquery-ui are vulnerable to a cross-site scripting vulnerability when arbitrary user input is supplied as the value of the closeText parameter in the dialog function.

jQuery-UI is a library for manipulating UI elements via jQuery.

Version 1.11.4 has a cross site scripting (XSS) vulnerability in the closeText parameter of the dialog function. If your application passes user input to this parameter, it may be vulnerable to XSS via this attack vector.

Recommendation

Upgrade to jQuery-UI 1.12.0 or later.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.webjars.npm:jquery-uiall versions1.12.0org.webjars.npm:jquery-ui:1.12.0
📦npmjquery-uiall versions1.12.0npm install jquery-ui@1.12.0
.NETNuGetjQuery.UI.Combinedall versions1.12.0dotnet add package jQuery.UI.Combined --version 1.12.0
💎RubyGemsjquery-ui-railsall versions6.0.0bundle update jquery-ui-rails --conservative

Affected Products

13 products · 23 configurations
OS
debian linuxdebian
1 version
9.0
OS
fedorafedoraproject
3 versions
303536
Application
jquery uijqueryui
≥ 1.10.0 && ≤ 1.11.4
range
OS
junosjuniper
1 version
21.2
Application
snapcenternetapp
all
Application
application expressoracle
< 19.1
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.webjars.npm:jquery-ui, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.webjars.npm:jquery-ui to 1.12.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-7103 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatLow

Red Hat Enterprise Satellite 5 is now in phase 3 of the support and maintenance life cycle. This issue is not currently planned to be addressed in future updates. For additional information, refer to the Red Hat Satellite 5 Life Cycle: https://access.redhat.com/support/policy/updates/satellite.

ProductFixed inAdvisory
Red Hat Enterprise Linux OpenStack Platform 7.0 (Kilo) for RHEL 7python-XStatic-jquery-ui-0:1.12.0.1-1.el7ostRHSA-2017:0161
Red Hat OpenStack Platform 8.0 (Liberty)python-XStatic-jquery-ui-0:1.12.0.1-1.el7ostRHSA-2016:2932
Red Hat OpenStack Platform 9.0 (Mitaka)python-XStatic-jquery-ui-0:1.12.0.1-1.el7ostRHSA-2016:2933

Frequently Asked Questions

Affected versions of `jquery-ui` are vulnerable to a cross-site scripting vulnerability when arbitrary user input is supplied as the value of the `closeText` parameter in the `dialog` function. jQuery-UI is a library for manipulating UI elements via jQuery. Version 1.11.4 has a cross site scripting (XSS) vulnerability in the `closeText` parameter of the `dialog` function. If your application passes user input to this parameter, it may be vulnerable to XSS via this attack vector. ## Recommendation Upgrade to jQuery-UI 1.12.0 or later.
O3 Security · Impact-Aware SCA

Is CVE-2016-7103 in your dependencies?

Find it across Maven, npm, NuGet, including transitive dependencies.

CVE-2016-7103: jquery-ui XSS — Fixed in 1.12.0