CVE-2021-4041 is a high-severity (CVSS 7.8) Improper Input Validation vulnerability in ansible-runner. A fix is available for ansible-runner — see the affected versions and patch details below.
ansible-runner vulnerable to shell command injection
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
ansible-runnerReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
A flaw was found in ansible-runner. An improper escaping of the shell command, while calling the ansible_runner.interface.run_command, can lead to parameters getting executed as host's shell command. A developer could unintentionally write code that gets executed in the host rather than the virtual environment.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | ansible-runner | all versions | 2.1.0pip install --upgrade 'ansible-runner==2.1.0' |
Affected Products
ansible runnerredhatDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ansible-runner, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update ansible-runner to 2.1.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-4041 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Satellite 6.12 and later versions are not affected by this flaw.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Ansible Automation Platform 2.0 for RHEL 8 | ansible-runner-0:2.0.3-2.el8ap | RHSA-2022:0108 |
Frequently Asked Questions
Is CVE-2021-4041 in your dependencies?
Find it across PyPI, including transitive dependencies.