NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

ansible-runner vulnerable to shell command injectionGHSA-6j58-grhv-2769

HIGHFix: ansible/ansible-runner@3533f26

GHSA-6j58-grhv-2769 is a high-severity (CVSS 7.8) Improper Input Validation vulnerability in ansible-runner. A fix is available for ansible-runner — see the affected versions and patch details below.

Also known asCVE-2021-4041PYSEC-2022-253
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs27th percentile — riskier than 27% of all scored CVEsHighest risk
0.00%0.28%0.55%0.83%0.1%0.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍ansible-runner

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

A flaw was found in ansible-runner. An improper escaping of the shell command, while calling the ansible_runner.interface.run_command, can lead to parameters getting executed as host's shell command. A developer could unintentionally write code that gets executed in the host rather than the virtual environment.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIansible-runnerall versions2.1.0pip install --upgrade 'ansible-runner==2.1.0'

Affected Products

1 product · 4 configurations
Application
ansible runnerredhat
< 2.1.0
1 version
2.1.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ansible-runner, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ansible-runner to 2.1.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-6j58-grhv-2769 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

Satellite 6.12 and later versions are not affected by this flaw.

ProductFixed inAdvisory
Red Hat Ansible Automation Platform 2.0 for RHEL 8ansible-runner-0:2.0.3-2.el8apRHSA-2022:0108

Frequently Asked Questions

A flaw was found in ansible-runner. An improper escaping of the shell command, while calling the `ansible_runner.interface.run_command`, can lead to parameters getting executed as host's shell command. A developer could unintentionally write code that gets executed in the host rather than the virtual environment.
O3 Security · Impact-Aware SCA

Is GHSA-6j58-grhv-2769 in your dependencies?

Find it across PyPI, including transitive dependencies.

GHSA-6j58-grhv-2769: ansible-runner — Fixed in 2.1.0