Your RSA-2048 keys break in 2030. Find every one of them before attackers do.
🦀 crates.io📦 npm
Not in CISA KEV

Cedar: JSON template is in scope missing slot-id validation allows link panic and decision divergenceGHSA-c33x-vcv4-vg3g

GHSA-c33x-vcv4-vg3g is a security vulnerability in cedar-policy. A fix is available for cedar-policy — see the affected versions and patch details below.

Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Oct 29, 2026 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

4 pkgs affected
🦀cedar-policy🦀cedar-policy📦@cedar-policy/cedar-wasm📦@cedar-policy/cedar-wasm

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io, npm packages — download data is not available via public APIs for these ecosystems.

Description

Cedar users must be using all of the following features to be affected by this advisory: JSON format policies, policy templates, and the is in scope condition. This advisory only affects JSON-formatted Cedar policy templates containing is in scope conditions that are malformed according to the Cedar syntax. It does not affect syntactically well-formed policies.

Users of Cedar who author policies in the JSON format were able to write Cedar policies using the is in condition with an incorrect slot identifier in the principal and resource scope constraints (e.g., ?principal in the resource scope constraint) even though this is not allowed when parsing policies from the Cedar policy syntax. Internally, the slot identifiers were silently corrected (e.g. ?resource is placed in the resource scope constraint).

If the policy contains exactly one slot in either the principal or resource position, then any attempt to create a linked policy from the template results in an error: the internal representation of the template does not contain the slot identifier as written in the malformed JSON policy (it has been corrected silently), so attempting to fill that slot is an error. If instead the template is linked using slot identifier expected internally (i.e., not what is written in the JSON template), the linking will initially succeed, but a subsequent invariant violation will cause a panic.

When the template contains slots in both the principal and resource position, then both slots will be present in the internal representation: linking succeeds, but with each slot bound to the value intended for the other (the silent correction). The linked policy is then semantically different from the malformed policy the user intended, and any subsequent authorization decision made against that policy may lead to accesses being unintentionally allowed or denied.

Concretely, consider the following JSON format policy template intended to deny users in a particular project from accessing documents with a particular classification.

{
  "effect": "forbid",
  "principal": {
    "op": "is",
    "entity_type": "User",
    "in": { "slot": "?resource" }
  },
  "action": { "op": "All" },
  "resource": {
    "op": "is",
    "entity_type": "Doc",
    "in": { "slot": "?principal" }
  },
  "conditions": []
}

Linked with ?principal = Classification::"topsecret" and ?resource = Project::"alpha", the author expects to create the policy:

forbid(principal is User in Project::"alpha", action, resource is Doc in Classification::"topsecret");

But because Cedar internally links slots by scope position (not by name), the actual policy evaluated by the engine is:

forbid(principal is User in Classification::"topsecret", action, resource is Doc in Project::"alpha");

If a user is in Project::"alpha" but not Classification::"topsecret", the forbid policy does not apply, and access is unintentionally allowed.

Patches

This advisory is patched in version 4.11.1 and 3.4.3, both available on Crates.io and NPM.

Workarounds

If you cannot update to a patched version, you can determine if you are affected by checking your JSON format policy templates for the following two patterns.

  "principal": {
    "op": "is",
    "entity_type": "User",
    "in": { "slot": "?resource" }
  }

and

  "resource": {
    "op": "is",
    "entity_type": "Doc",
    "in": { "slot": "?principal" }
  }

References

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🦀crates.iocedar-policy≥ 4.0.0&&< 4.11.14.11.1cargo update -p cedar-policy --precise 4.11.1
🦀crates.iocedar-policy≥ 3.0.0&&< 3.4.33.4.3cargo update -p cedar-policy --precise 3.4.3
📦npm@cedar-policy/cedar-wasm≥ 4.0.1&&< 4.11.14.11.1npm install @cedar-policy/cedar-wasm@4.11.1
📦npm@cedar-policy/cedar-wasm≥ 3.2.0&&< 3.4.33.4.3npm install @cedar-policy/cedar-wasm@3.4.3

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for cedar-policy, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update cedar-policy to 4.11.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-c33x-vcv4-vg3g is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Cedar users must be using all of the following features to be affected by this advisory: JSON format policies, policy templates, and the `is in` scope condition. This advisory only affects JSON-formatted Cedar policy templates containing `is in` scope conditions that are **malformed** according to the Cedar syntax. It does **not** affect syntactically well-formed policies. Users of Cedar who author policies in the JSON format were able to write Cedar policies using the `is in` condition with an incorrect slot identifier in the principal and resource scope constraints (e.g., `?principal` in th
O3 Security · Impact-Aware SCA

Is GHSA-c33x-vcv4-vg3g in your dependencies?

Find it across crates.io, npm, including transitive dependencies.