NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
CRITICAL severity

CVE-2021-3985 — kimai2

CRITICALFix: kevinpapst/kimai2@76e0944

CVE-2021-3985 is a critical-severity (CVSS 9) Cross-site Scripting (XSS) vulnerability in kevinpapst/kimai2. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for kevinpapst/kimai2 — see the affected versions and patch details below.

kimai2 is vulnerable to Cross-site Scripting

Also known asGHSA-x68c-4gmm-5g43
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs70th percentile — riskier than 70% of all scored CVEsHighest risk
0.00%0.59%1.17%1.76%0.4%1.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘kevinpapst/kimai2

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

kimai2 is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistkevinpapst/kimai2all versions1.16.3composer require kevinpapst/kimai2:^1.16.3

Affected Products

1 product · 1 configurations
Application
kimai2kimai
< 1.16.3
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for kevinpapst/kimai2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update kevinpapst/kimai2 to 1.16.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-3985 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

kimai2 is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
O3 Security · Impact-Aware SCA

Is CVE-2021-3985 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2021-3985: kimai2 XSS — Fixed in 1.16.3