NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2021-3963 — kimai2

MEDIUMFix: kevinpapst/kimai2@95796ab

CVE-2021-3963 is a medium-severity (CVSS 4.3) Cross-Site Request Forgery (CSRF) vulnerability in kevinpapst/kimai2. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for kevinpapst/kimai2 — see the affected versions and patch details below.

Cross-site Scripting in kimai2

Also known asGHSA-gf2c-93hm-r9j5
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs34th percentile — riskier than 34% of all scored CVEsHighest risk
0.00%0.30%0.60%0.90%0.1%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘kevinpapst/kimai2

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

kimai2 is vulnerable to Cross-Site Request Forgery (CSRF) in deleting invoice templates. This vulnerability is capable of tricking admin user to delete invoice templates.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistkevinpapst/kimai2all versions1.16composer require kevinpapst/kimai2:^1.16

Affected Products

1 product · 1 configurations
Application
kimai 2kimai
< 1.16.2
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for kevinpapst/kimai2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update kevinpapst/kimai2 to 1.16 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-3963 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

kimai2 is vulnerable to Cross-Site Request Forgery (CSRF) in deleting invoice templates. This vulnerability is capable of tricking admin user to delete invoice templates.
O3 Security · Impact-Aware SCA

Is CVE-2021-3963 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2021-3963: kimai2 CSRF — Fixed in 1.16