NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2019-15481 — kimai2

MEDIUMFix: kevinpapst/kimai2#962

CVE-2019-15481 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in kevinpapst/kimai2. A fix is available for kevinpapst/kimai2 — see the affected versions and patch details below.

Kimai v2 is vulnerable to Cross-Site Scripting (XSS)

Also known asGHSA-7v44-75jf-22gj
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs59th percentile — riskier than 59% of all scored CVEsHighest risk
0.00%0.45%0.91%1.36%0.2%0.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘kevinpapst/kimai2

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Kimai v2 before 1.1 has XSS via a timesheet description.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistkevinpapst/kimai2all versions1.1composer require kevinpapst/kimai2:^1.1

Affected Products

1 product · 1 configurations
Application
kimai 2kimai
< 1.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for kevinpapst/kimai2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update kevinpapst/kimai2 to 1.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-15481 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Kimai v2 before 1.1 has XSS via a timesheet description.
O3 Security · Impact-Aware SCA

Is CVE-2019-15481 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2019-15481: kimai2 XSS — Fixed in 1.1