NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2021-37714 — jsoup

HIGH

CVE-2021-37714 is a high-severity (CVSS 7.5) CWE-248 vulnerability in org.jsoup:jsoup. A fix is available for org.jsoup:jsoup — see the affected versions and patch details below.

Uncaught Exception in jsoup

Also known asGHSA-m72m-mhq2-9p6c
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2021-37714.

EPSS Exploitation Probability

via FIRST.org ↗
6.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs94th percentile — riskier than 94% of all scored CVEsHighest risk
3.59%4.94%6.28%7.63%4.4%6.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.jsoup:jsoup

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Impact

What kind of vulnerability is it? Who is impacted? Those using jsoup to parse untrusted HTML or XML may be vulnerable to DOS attacks. If the parser is run on user supplied input, an attacker may supply content that causes the parser to get stuck (loop indefinitely until cancelled), to complete more slowly than usual, or to throw an unexpected exception. This effect may support a denial of service attack.

Patches

Has the problem been patched? What versions should users upgrade to? Users should upgrade to jsoup 1.14.2

Workarounds

Is there a way for users to fix or remediate the vulnerability without upgrading? Users may rate limit input parsing. Users should limit the size of inputs based on system resources. Users should implement thread watchdogs to cap and timeout parse runtimes.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jsoup:jsoupall versions1.14.2org.jsoup:jsoup:1.14.2

Affected Products

16 products · 24 configurations
Application
jsoupjsoup
< 1.14.2
range
Application
management services for element software and netapp hcinetapp
all
Application
banking trade financeoracle
1 version
14.5
Application
banking treasury managementoracle
1 version
14.5
Application
business process management suiteoracle
2 versions
12.2.1.3.012.2.1.4.0
OS
communications messaging serveroracle
1 version
8.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jsoup:jsoup, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jsoup:jsoup to 1.14.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-37714 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
EAP 7.3.10 GAjsoupRHSA-2021:5154
Red Hat build of Quarkus 2.2.5jsoupRHSA-2022:0589
Red Hat EAP-XP 2 via EAP 7.3.x basejsoupRHSA-2022:0146
Red Hat Fuse 7.10jsoupRHSA-2021:5134
Red Hat JBoss Enterprise Application Platformorg.jsoup/jsoup:1.14.2.redhat-00002RHSA-2021:4679
Red Hat JBoss Enterprise Application Platform 7.1 EUS for RHEL 7eap7-activemq-artemis-0:1.5.5.016-1.redhat_00001.1.ep7.el7RHSA-2025:4226
Red Hat JBoss Enterprise Application Platform 7.3 for RHEL 6eap7-apache-cxf-0:3.3.12-1.redhat_00001.1.el6eapRHSA-2021:5149
Red Hat JBoss Enterprise Application Platform 7.3 for RHEL 7eap7-apache-cxf-0:3.3.12-1.redhat_00001.1.el7eapRHSA-2021:5150

Frequently Asked Questions

### Impact _What kind of vulnerability is it? Who is impacted?_ Those using jsoup to parse untrusted HTML or XML may be vulnerable to DOS attacks. If the parser is run on user supplied input, an attacker may supply content that causes the parser to get stuck (loop indefinitely until cancelled), to complete more slowly than usual, or to throw an unexpected exception. This effect may support a denial of service attack. ### Patches _Has the problem been patched? What versions should users upgrade to?_ Users should upgrade to jsoup 1.14.2 ### Workarounds _Is there a way for users to fix or remed
O3 Security · Impact-Aware SCA

Is CVE-2021-37714 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2021-37714: jsoup DoS — Fixed in 1.14.2